Stupid El Capitan :(  1-20  21

Next
 From:  Stardust
7783.1 
Hi Moi'ers

Someone have a solution for viewports being totally messed up after upgrading to El f**k Capitan??
Loads of trouble has occurred for me with selecting fullscreen viewport?

/edit..I have updated the wineskin and also the settings to change the bottom 2 checkboxes on that page - unchecked "use wrapper's quartz-wm" and checked the "use System XQuartz"

Thanks

BR
Stardust


- Michael for Nobel Prize -
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7783.2 In reply to 7783.1 
Hi Stardust, there is an MoI version 3.1 update which should fix that problem, you can get it by putting in your license key here:
http://moi3d.com/reinstall.htm

That 3.1 updated version should run fine in El Capitan without needing to modify any wineskin settings anymore and it fixes the viewport display problem.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Stardust
7783.3 In reply to 7783.2 
Hi Michael

Ok, thanks :)



BR
Stardust


- Michael for Nobel Prize -
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Teddy
7783.4 In reply to 7783.1 
This brings up a question.

I'm about to switch from PC to Mac, and wanted to get some feedback on how the Mac version of MoI performs compared to the PC version.

Thanks!
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  TpwUK
7783.5 In reply to 7783.4 
MoI v3.1 for OS X works like a charm on both unsupported Hackintosh and the official Mac OS X version 9.3 through 10.11.x running on Mac Pro 3.1 and upwards :)

Martin
(TpwUK)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7783.6 In reply to 7783.4 
Hi Teddy, as far as I have seen and heard the performance of the Mac version has been fine.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Teddy
7783.7 In reply to 7783.6 
Wonderful to hear! Thank you.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  foehnsturm
7783.8 
Just a short question: Are 3D input devices (SpaceMouse) still working with El Capitan and release 3.1?
Used to work perfectly with earlier OSX and release 3.0. But since the OSX update the 3d mouse is dead within Moi3d.
I'd suspect it's an issue with wineskin and El Capitan as the mouse works with native apps. But I don't have an idea how to solve it.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  chippwalters
7783.9 In reply to 7783.8 
Working fine on my El Capitan.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  TpwUK
7783.10 In reply to 7783.9 
If i remember Chipp didn't you have to roll-back to a previous driver version or am i mixing you up with someone else ?

Martin
(TpwUK)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7783.11 In reply to 7783.8 
Hi foehnsturm, some information in this thread:
http://moi3d.com/forum/index.php?webtag=MOI&msg=7676.2

Try finding their driver version 10.1.2 and use that one.

I posted a question about it last October in the 3DConnexinon Developers Forum for OS X but they have not replied to it.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  foehnsturm
7783.12 
Thanks very much Michael!

Excellent software, Excellent support.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  raytownmike (HOPPER)
7783.13 In reply to 7783.12 
After installing 3.1 how do I get the custom interface back?
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7783.14 In reply to 7783.13 
Hi mike,

> After installing 3.1 how do I get the custom interface back?

You have to copy over the same files into 3.1 that you did with 3.0 .

In this case since there were no changes in the UI from 3.0 to 3.1 you can copy over the entire UI directory from your customized v3. To do that right-click on the MoI v3 shortcut and choose "show package contents". Then inside there go to drive_c/moi/ui . Do the same thing with version 3.1 , then copy all the files in the v3 ui directory over into the v3.1 ui directory overwriting the existing ones.

If you have installed any custom commands in the commands folder previously then you will want to copy those over as well, from the v3 commands folder (drive_c/moi/commands) to the v3.1 commands folder.

- Michael

EDITED: 10 Feb 2016 by MICHAEL GIBSON

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  raytownmike (HOPPER)
7783.15 In reply to 7783.14 
You must get this question all of the time. Thanks as usual!!!
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  BLADE
7783.16 
I have some strange behaviors with MOI 3.1 on OS X. I am using an iMac 5K late 2015 in its highest configuration with two extra monitors.

When pushing the Moi window to one of the extra monitors and then go to full screen mode with Moi, the Moi window sometimes disappears.

When trying to export something, often the export-window is under the Moi main window but I am unable to bring the export windows to the front.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7783.17 In reply to 7783.16 
Hi Blade - it has to do with the multiple monitors. The "Wineskin" system that the MoI Mac version currently uses has not yet caught up to changes in how multiple monitors work in recent Mac OS versions.

There is a system setting that you can change to go back to the previous style OS multi-monitor behavior which should then make MoI work ok. That setting is under System Preferences > Mission Control - uncheck "Displays have separate Spaces" there. You will then need to reboot your system in order for this change to take effect.

This should be fixed up better in MoI v4 which will not use the wineskin mechanism anymore, but it will still be a while yet before v4 is ready.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Jacob
7783.18 
Hopefully Wine will fix this bug sooner rather than later. :-)

Out of curiosity, is MoI for OSX essentially a Windows version wrapped in Wineskin or are there any significant differences in the build?
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7783.19 In reply to 7783.18 
Hi Jacob,


> Hopefully Wine will fix this bug sooner rather than later. :-)

The bug is actually in the XQuartz layer, not in Wine. It does not look like it will be fixed anytime soon here are some bug reports about it:
https://xquartz.macosforge.org/trac/ticket/797
https://xquartz.macosforge.org/trac/ticket/796
https://xquartz.macosforge.org/trac/ticket/817

But I expect it to be solved in MoI v4 since it won't use XQuartz anymore.


> Out of curiosity, is MoI for OSX essentially a Windows version wrapped in Wineskin or
> are there any significant differences in the build?

For the most part it's the windows version wrapped in Wineskin, but there is also some native code integration for a few key areas like showing the file open dialog and getting multitouch events.

I am working on changing this for MoI v4 though, so that v4 will be a native compiled version on OS X and Wineskin won't be used anymore. This involves a whole lot of work though and is still in progress.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bisenberger
7783.20 In reply to 7783.2 
The file I downloaded from http://moi3d.com/reinstall.htm is Version 3.0 Sep-18-2014. Is version 3.1 just for macs?

EDITED: 24 Mar 2016 by BISENBERGER

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
Show messages:  1-20  21