New Jun-12-2007 beta available now.  1-5  6-25  26-36

Previous
Next
 From:  Edwin (EDWINTSI)
670.6 In reply to 670.5 
GREAT WORK Michael.
The LWO exporter kicks N-GON :-)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Josugh
670.7 In reply to 670.1 
Great Work!!!

I am Testing too the options for LWO export.
I will continue bugs if I found them!! Cause I am working a lot with this program now.

In lightwave the exporter is now 99% OK!!!... Is first time in the morning here in Spain but I am making tests with my complex models from Solid Edge,
and the only bug that I fond is some Polygons that have wrong normals, but is easy to fix putting double sided in the surface editor.
( there are only 5-6 polygons in a object with 80.000 don´t worry.... The perfection doesn´t exists but you are so NEAR!!!
( I make more tests with the same piece and I don´t found fliped surfaces!!! WOW!!)

THANK YOU VERY MUCH!!!!!!!!!!

I continue working / testing.
Best Regards
Josu
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Frenchy Pilou (PILOU)
670.8 
French Version Up dated for the New Jun-12-2007 beta
Unzip and replace in the folder ...Program Files\MoI beta Jun-12-2007\ui
Have fun!
French Forum http://moi3d.com/forum/messages.php?webtag=MOI_FRANCAIS&msg=28.1
---
Pilou
Is beautiful that please without concept!
My Gallery

EDITED: 24 Jun 2007 by PILOU

Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Frenchy Pilou (PILOU)
670.9 
No AI export format?
---
Pilou
Is beautiful that please without concept!
My Gallery
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Buzhug
670.10 
Thanks a lot Michael.
You're really the best.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  jacobo3d
670.11 In reply to 670.4 
Hi Michael,

> On the ones I saw, I couldn't find anything wrong with the n-gon, it was well formed, points were spaced well without
> anything stacked up or reversed or anything.. Just the triangles for the n-gon display were coming outside the n-gon.

Actually, I've found this kind of problem, but I kind of expected something like this to happen with some complex n-gons.
The thing is, it's something very easy to fix. Using 'divide larger than' option in Moi, or just slice that polygon directly in
LW/modo.

> Because if you do see problems with the n-gon structure such as duplicate points within one polygon or n-gons with messy
> edges that cross over other edges, etc..., then those would be things I need to fix up in MoI. Otherwise if there is nothing
> wrong with the n-gon these look to me like triangulation bugs in LightWave. But so much fewer in number than with OBJ import.
> I guess they must have 2 totally separate pieces of triangulation code, otherwise I can't see how the LWO one would be mostly
> pretty good and the OBJ one so bad...

And here comes the problem. I've got messy edges in some n-gons as well. Actually the only way to fix it was remove those
n-gons and create them again in modo/LW. I'll send you some screen captures tomorrow, and I'll see if I can send you the
problematic object.

> Hmmm, this sounds like a bug. Normally it is intended that every different single joined object in MoI should go on its own
> separate layer in the LWO file. If you can send me the smallest .3dm example file you've got that has this problem, that
> might help me figure it out.

I'll get one of the objects that gave me that problem and I'll send it to you tomorrow as well.


> Was this with weld turned on or off? If weld is turned off then that's normal, but if weld is turned on it is supposed to merge
> those and that's probably a bug. If you have an example that needs merge vertices even though you exported with weld on,
> please send it if you can.

I've noticed that it was disabled by default (I guess for the LWO exporter... I didn't try the OBJ in the new beta), so I did another
test with that option enabled, and I still got unwelded vertices (they seemed not so many than before though).
And sure, I'll send you an example of this tomorrow!


> Thanks very much for the testing! I'm glad this is working better for you than the other ways of exporting before.

No problem! :) Thank you for the new beta.

Jacobo.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  WillBellJr
670.12 In reply to 670.11 
Thanks so much for the new update Michael, the bond between MOI and Lightwave for me is getting deeper and deeper!

So for the shapes I've been working with, I've had ZERO rework to do - I'm even texturing stuff now, something I rarely got the chance to do due to having to deal with reworking first...

GREAT release! MOI is definitely v1.0 ready!

-Will
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Richard (RUSIRIUS)
670.13 
More greatness Michael!
Thank you. This is one massive update :)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  sk2k
670.14 
Hi,

here is the updated German translation.

MfG
sk2k
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
670.15 In reply to 670.9 
Hi Pilou,

> No AI export format?

Not yet, this one only has AI import, not export.

Export will be coming for the next beta though.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Schbeurd
670.16 
Nice update...
Currently, I don't really have time to play with MoI but I will certainly make some tests on the LWO export for Modo and the AI import.
And also the update on the loft command. Is it related to the "problem" I had with mesh symmetry ?

And AI export in the next beta ! Yessss ! ;-) (And I see on French ZBrush forum that Steph3D waits for it too !)

Thanks Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
670.17 In reply to 670.16 
Hi Bernard,

> Is it related to the "problem" I had with mesh symmetry ?

Yup! A closed loft should behave better now and not have the slight shift in it that caused your previous symmetry problem.

The quad meshing improvement also helps with symmetry - this enables an n-gon that looks exactly like a single column of quads to be split into quads instead of triangulated (in quads & triangles export mode). This also improves symmetry for that shape you previously posted.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Schbeurd
670.18 In reply to 670.17 
>> The quad meshing improvement also helps with symmetry - this enables an n-gon that looks exactly like a single column of quads to be split into quads instead of triangulated (in quads & triangles export mode). This also improves symmetry for that shape you previously posted.

Cool ! I think I'm gonna enjoy using MoI objects inside Modo and ZBrush... ;-) I'll try to find some time to make tests during the next week-end.
The news in another thread about vertex smoothing support in Modo 301 is interesting too... Things are going in the good direction, hehe...

Greetings
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  MFort
670.19 
Wow Michael! You and MoI continue to impress.Really great work. I've been a bit scarce lately I just wanted to let you know that I'm still lurking waiting for the buy button to pop up. I just wish I would have paid some attention to that geometry class 20 odd years ago.

Cheers!

Matt
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
670.20 In reply to 670.11 
Hi Jacobo,

re: Weld setting

> I've noticed that it was disabled by default (I guess for the LWO exporter... I
> didn't try the OBJ in the new beta),

It's one of the few settings (along with display type and polygon type (ngons, triangles) that is remembered between different sessions. So probably in a previous session you had turned it off.


> so I did another test with that option enabled, and I still got unwelded vertices
> (they seemed not so many than before though). And sure, I'll send you an
> example of this tomorrow!

An example of that one would be great, that sounds like a bug. Just one more note - surfaces have to be joined for the weld setting to have an effect.

It could also possibly be a bug in join, if join does not manage to properly glue together 2 edges (even though others were combined), it would result in this kind of a thing too. I can tell that by examining the model though.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
670.21 In reply to 670.7 
Hi Josu, thanks for testing the new LWO export!

99% is pretty good for version 1.0 ! :)

On ones that do generate a few incorrect polygons, if you can send any example models to me, that would help me figure out how to solve that. (it is helpful if you narrow it down to the smallest piece that shows a problem).

I would like to get closer to 100% !

But I am glad that the LWO format is working well for you - at least it is quick to fix 5 or 6 bad polys out of 80,000 - it's a lot better than fixing 2,000 bad ones...

I'm almost ready to take a look at some of the other bugs that you sent previously.

Thanks!

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  jnge100
670.22 In reply to 670.21 
Hello Michael,

Thanks again for this enhanced version. One question (for me at least) remains however. In several instances you promised us support in V1 for the 3dconnexion navigation devices, such as the spacemouse for example. Will it still be included in the V1? (I most certainly hope so).
Best Regards Hans
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
670.23 In reply to 670.22 
Hi Hans, yes I'm planning on including this with the next beta. Sorry I wasn't able to get it into this one.

The main remaining features left to work on are Adobe Illustrator export, and 3D Connexion support.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  d^^b (DAVID)
670.24 
The spanish translation...

Enjoy it!

Bye
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
670.25 In reply to 670.24 
Thanks David! By the way, do you remember those boat hull sections you sent to me a few months ago that would not loft?

The new beta fixes this, those now loft fine. That's what the new stuff about the Profiles option is about.

For lofting through a larger number of curves, it is often nice to use Loft Style = "Loose" to get a more relaxed surface, the ones you sent work pretty well if you use the loose style. The regular style can cause sort of bumps when you use many sections.

Another thing that can help get smooth lofts through many sections is to use the new Profiles: #Points option, this will further simplify the resulting loft by using only the number of control points that you specify for rebuilding the profiles. This will only be a somewhat rough approximation of your input curves, but the result will be even more smooth yet.

So for instance using Loft Style = "Loose" as well as Profiles = #Points with 10 points, will generate a really smooth surface from the 13 cross-sections that you had for that boat hull.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
Show messages:  1-5  6-25  26-36