The Globes and the Dimples
 1-15  16-35  36-44

Previous
Next
 From:  Richard (RUSIRIUS)
979.16 
Sweet plug-in anthony! Works great.

Thank you :)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Alain
979.17 
Hi Anthony
Thanks for this plugin.

It seems that I'm to stupid to get good results with it.
I just tested it with a freeform surface, used "N-gons" and turned off "weld vertices along edges" and "Angle" is 12 (degree?), see "Freiflaechentest_N-Gones_001.jpg".
One test is with "triangles only" insteat of "N-gons", see "Freiflaechentest_only_triangles_002.jpg".

I love Moi but it would be useless for me if I never can import proper models from moi into another 3d software like blender.

I hope somebody can help me for a proper export-import process ?


Kind regards
Alain











  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.18 In reply to 979.17 
Hi Alain, that's the kind of shading problems that you can see if vertex normals are not being imported properly.

Are you sure you are using Anthony's importer?

One thing to note is that after installing Anthony's importer, you must pick it off of the import list separate from the default LWO importer which will still show up there.

Anthony's one is labeled MoI with Normals, as shown below. Make sure to pick that one and not the default LWO importer.

Also if you can post the 3DM model file of the thing you are trying to export, that would make it easier for me to test with it directly and show you what to do.



- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.19 In reply to 979.17 
Hi Alain, also you can try the OBJ importer from this post:
http://moi3d.com/forum/index.php?webtag=MOI&msg=3164.11

The default OBJ importer for Blender was throwing away the vertex normals at the end of the load, I modified the one in the post above to maintain the vertex normals which helps to get much nicer smooth shading.


You may also want to use the "Divide larger than" parameter in the meshing options, to force some additional divisions of the polygons in your model there. When you have triangles that span a pretty large length of the model that can tend to make for more rendering artifacts.

If you enter in a distance value for "Divide larger than", any polygons larger than that distance will be broken down into smaller pieces which tends to render better even without vertex normals being present.

If you post your model, I'll show you an example with it.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Alain
979.20 
Hi Michael

Thanks for your quick answer :)

Yes I use the importscript as you discribed it.
Here is the *.3dm file.

I hope it helps.


Alain

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Alain
979.21 In reply to 979.20 
Thanks Micheal, it was the option "divide larger than" which gave me the possibility to divide those long triangles.

It's still not quit perfect (see attachement, use triangles and quads. using n-gons is a little bit better).

Edit:
I used the Import-Script of Anthony. Your modified OBJ-Import gives me about the same results as Anthony's script.

Alain
Image Attachments:
Size: 68.2 KB, Downloaded: 108 times, Dimensions: 1280x1024px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.22 In reply to 979.21 
Hi Alain,

> It's still not quit perfect (see attachement, use triangles and
> quads. using n-gons is a little bit better).

It looks like there were not a lot of polygons created on that tightly curved area.

What parameters are you using, still only an angle of 12?

If you want to have a smoother look on curved areas, reduce the angle a bit more (move the slider towards the "more polygons" side a bit), bring it down to something like 8 and that will make more polygons on curved areas and give it a smoother appearance.

The angle parameter helps to make more divisions on tightly curved areas - if you have areas that are larger and more shallowly curved then also use a distance value in "Divide larger than" to help refine those kinds of areas more.

Blender's renderer seems to be somewhat sensitive to having much change between each polygon, so you may need to produce a fairly fine mesh if you want to have a super smooth looking rendered result. Some other kinds of renderers are not quite as sensitive.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.23 In reply to 979.21 
Hi Alain, also in your last image there it is possible that you are getting some general rendering artifacts such as "self shadowing" on polygons that are nearly vertical to the light source or things similar to that.

It is possible that you could solve that by tweaking some kinds of rendering parameters, or maybe by moving the light over a bit or things like that.

If you produce a denser mesh by using a tighter angle, it can help to make some kinds of rendering artifacts be reduced.


Remember - when you're dealing with polygons the data you are working with is actually made up of some completely flat facets, it is only some kinds of display tricks that make things appear as if they were actually smooth.

If you use more polygons, some of those display tricks get a bit higher accuracy because the actual faceted shape begins to more closely approximate a true curved surface instead of a faceted one.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Alain
979.24 In reply to 979.23 
Hi Michael, thanks for your support.

I get the best result with the "Divide larger than" parameter.

Good to know it is renderer depending. I just tried it with the Blender internal renderer but I will never render it with it for a final image.

What renderers work good with Moi imported models ? Yafaray ? V-Ray ?
I also have been reading the thread about the octane renderer, how far is radiance with his tests ?


Kind regards
Alain
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.25 In reply to 979.24 
Hi Alain,

> What renderers work good with Moi imported models ?
> Yafaray ? V-Ray ?

I'd think either of those would be fine, I'd guess that Modo and Cinema4D seem to be the most frequently used but MoI has been used in combination with a pretty wide range of different renderers.

Check out the MoI gallery here: http://moi3d.com/gallery/ there are a whole lot of rendered images in there, most of them mention which rendering program was used.


> I also have been reading the thread about the octane renderer,
> how far is radiance with his tests ?

I'm not sure, I think it is still a work in progress.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.26 In reply to 979.24 
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Phil (PHILBO)
979.27 
To be completely accurate,

http://moi3d.com/gallery/viewitem.php?id=98

and

http://moi3d.com/gallery/viewitem.php?id=149

were both imported into Blender and then rendered using Luxrender.

They were not rendered using Blender's internal rendering engine.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.28 In reply to 979.27 
Hi Phil, yeah maybe Alain will need to give some more information on what tools he wants to use, but it sounded to me like wanted to use Blender in combination with some additional renderer instead of the Blender internal one.

So those are a couple of examples of that kind of workflow...

Sorry when I said those were done with Blender I meant more like "using Blender as part of the toolchain".

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Alain
979.29 
Yes, I don't have in mind to render final images with the blender internal renderer ;-)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  NightCabbage
979.30 
Ok, so possibly dumb question, but...

I am running the Blender 2.5 version from Anthony's website, and when I start blender (with the import moi python script) I get this error:

Traceback (most recent call last):
File "C:\DOCUME~1\NIGHTC~1\Desktop\TRUE-N~1.5\BLENDE~1\.blender\scripts\module
s\bpy\utils.py", line 44, in _test_import
mod = __import__(module_name)
File "C:\DOCUME~1\NIGHTC~1\Desktop\TRUE-N~1.5\BLENDE~1\.blender\scripts\io\imp
ort_moi.py", line 54
print ctype
^
SyntaxError: invalid syntax

 

 

Is anyone else running the 2.5 version? Do you get this error?


-EDIT-

Ok, after some quick research, I've found out that Blender 2.5 uses Python 3, and the print command must have parentheses around its parameters.

I don't really know Python... is there a new version of the script for the 2.5 version of Blender?

EDITED: 7 Jul 2010 by NIGHTCABBAGE

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.31 In reply to 979.30 
Hi NightCabbage,

> I don't really know Python... is there a new version of the
> script for the 2.5 version of Blender?

Not that I know of.

I think that Anthony's website also has a modified build of Blender version 2.49 as well, probably the script will work fine if you use that one instead of the 2.5 version.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  NightCabbage
979.32 
lol yea I considered that, but my problem is taht I'm learning Blender, and the 2.4 interface is utterly hideous to learn :P

The 2.5 interface is just bad - but that's better than the 2.4 interface :D

Perhaps I'll modify the script for Python 3?

Surely Anthony must have a working version, or he wouldn't have bothered to make the changes to Blender 2.5, right?

(as I understand it, you need both the blender patch, and the import script in order for this to work, right?)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
979.33 In reply to 979.32 
Hi NightCabbage,

> (as I understand it, you need both the blender patch, and
> the import script in order for this to work, right?)

Yes, that's correct. The Blender patch stops the good normals from being thrown away during various operations including rendering.

But there won't be anything to preserve if you don't get the good normals imported in the first place. The import script is what handles that part, getting the good normals into Blender to start with.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  anthony
979.34 In reply to 979.33 
I finally rewrote the script for Python3.1/Blender2.5. I've been meaning to do this for a while and thought I'd wait until 2.5 became stable, but since there's some demand for it, I did it now. It's bundled with my current 2.5 build.

Note: Export with the vertex-welding option turned off. And do not use ngons for now.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  NightCabbage
979.35 
Haha, you made me a very happy Cabbage :D

Also, not that I really know what I'm talking about, but I believe you can use the following function that's sitting in the import_scene_obj.py script:

def BPyMesh_ngon(from_data, indices, PREF_FIX_LOOPS= True)

Should be the same as the original, I think? The author had to copy & paste it, as the bpymesh module is no longer present.



You have made my life much easier thanks to this <3
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
Show messages:  1-15  16-35  36-44