how to set up the object library

Next
 From:  Subroto
8824.1 
hi guys, I wanted to know how to set up the object library. I couldnt find a post regarding how to set it up.
Thanks,
Subroto
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  r2d3
8824.2 In reply to 8824.1 
Its a little bit hidden...
Open the Object library and go with the mouse over the text "ObjectLibrary" and there will a little + sign showing up -> click it -> give a name and the object in the 3d window will be in your objects library.

You can do it also manually if you put a 3dm and a png with the same name into the objects folder.

I'm using it for often used parts like a srew and i include cutting tools... makes it realy usefull -> to have a better pict of the part (without the cutting tools) i did first a +ObjectLibrary with only the screw and overwrote the 3dm file with the Screw+tools 3dm


Ralf:)
looking for moments of inspiration...
Attachments:

Image Attachments:
Size: 23.3 KB, Downloaded: 4 times, Dimensions: 400x320px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Subroto
8824.3 In reply to 8824.2 
Hi, I cant seem to find 'Object Library'itself? how do you locate it?
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  r2d3
8824.4 In reply to 8824.3 
You mean the Object Library from the CustomUi or?


Ralf:)
looking for moments of inspiration...
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Subroto
8824.5 In reply to 8824.4 
I can see the Obj library folder but it has nothing in it and i cant seem to add anything to it. there is no + sign that appears.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bemfarmer
8824.6 In reply to 8824.5 
When customUI is installed, at the bottom of the MoI screen, (command bar), the Obj Library icon shows.
Click the icon, and hover over Object Library text, in the popup window, for the + sign.

- Brian
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Subroto
8824.7 In reply to 8824.6 
Hi Brian,

I followed your instructions however i see no + sign popping up.

I'm attaching a screenshot.

Just to be sure if i installed the custom ui properly:

- i placed the 'custom ui' folder that I unzipped into the 'ui' folder in MOI.

is there anything else I should have done because I dont see Max's Objects in the object library. Its empty. And also the previous problem that it doesnt let me add anything?

Thanks,
Image Attachments:
Size: 204.8 KB, Downloaded: 15 times, Dimensions: 1920x1080px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  moritzbock (MORITZ)
8824.8 In reply to 8824.7 
Hi Subroto,

my objects directory is located in (Mac OS X)

/Users / YourName / Library / Application Support / Moi /customui

-moritz
Image Attachments:
Size: 422.1 KB, Downloaded: 29 times, Dimensions: 754x1127px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bemfarmer
8824.9 In reply to 8824.7 
Hi Subroto,

In Windows 7, MoI3
Before the switch to using the AppData/Roaming/Moi folder, the objects folder goes under c:\ProgramFiled(x86)\Moi3.0\objects. (your path may vary, maybe you call it MOI, not Moi3.0. (MOI is ok)

\objects folder does not go in Moi3.0\ui.
Both \objects folder and \ui folder and \commands folder, and snapshots folder, appear under \Moi3.0.

customui folder does go in Moi3.0\ui

******

For the AppData install,
my path is c:\Users\(mycomputername)\AppData\Roaming,
which contains customui folder, and objects folder and snapshots folder, as well as files moi.ini, and license key(s).

Sincerely
Brian

Do you have Apple computer?

EDITED: 14 Feb by BEMFARMER

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8824.10 In reply to 8824.7 
Hi Subroto,

> - i placed the 'custom ui' folder that I unzipped into the 'ui' folder in MOI.

Yeah I think the problem is you're unzipped one level too deep - the CustomUI (except for the brand newest one for v4) is expecting to be unzipped in the main MoI program folder, not inside of UI.

It should have 3 folders inside the .zip - objects, snapshots, and ui.

The ui part gets added in to the already existing MoI ui folder and objects and snapshots are siblings to the ui folder, not nested inside it.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Subroto
8824.11 
Ah, Thanks Michael. You solved it. I had unzipped it a level deeper. Its working fine now.

You guys are great!

Cheers,
Subroto
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Subroto
8824.12 In reply to 8824.11 
Hello,

So i can see the object library and the '+' sign, but I cant seem to save the objects. I select the object i want to save, I click the + sign, enter the name I want but nothing saves.
I checked the object library folder and its not saving it in that for some reason.
I can see Max'x default objects in the folder only.

Is there another place its saving these objects?

Cheers,
Subroto
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8824.13 In reply to 8824.12 
Hi Subroto, are you running on Windows? Does it work ok if you start MoI up with elevated privileges? That's when you right-click on the shortcut you're launching MoI with and choose "Run as Administrator".

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Subroto
8824.14 In reply to 8824.13 
Hi Michael,

I'm on windows and it worked with the 'Run as admin'.

Whats does that mean? and how do i enable this permanently?

Thanks,
Subroto
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8824.15 In reply to 8824.14 
Hi Subroto - there's a security measure in newer versions of Windows that prevents programs that are run at the regular privilege level from modifying the contents of the Program Files directory. That's what was preventing your object writing from working.

When you choose "Run as Administrator", that runs the program at a higher privilege level and then it's allowed to modify things in Program Files.

You can enable it permanently by right-clicking on that shortcut and choosing "Properties". Then on that properties dialog go to the Compatibility tab and near the bottom there's a "Privilege Level" section with a checkbox for "Run this program as an administrator". If you set that then it will run like that by default.

I think Max has an updated version of CustomUI for version 4 which moves these things over into the AppData folder which does not require elevated privileges.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Anton Kapelyushnik (ANTON)
8824.16 
Hi all.

If you go to [MoI installation folder]\ui\customui\mods and edit ObjLibrary.cfg you'll be able to type in new path.

Format:

[NAME that will appear in the UI for that library][COMMA or SEMICOLON][PATH in quotes]

Example from my ObjLibrary.cfg:

Object Library;"D:\OneDrive\nurbs\objlib"



Also you can have multiple object libraries. And they will be separated by line in UI. I believe for new entry you also need to separate it with comma or semicolon.
All above is true for MoI v3.

And yes, you have to edit ObjLibrary.cfg with administrator privileges. So in win search you type 'notepad' (or any other text-editor of your choice). Click on it with right mouse button. Choose 'Run as Administrator'. Then in notepad you open ObjLibrary.cfg, edit it and save it.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Subroto
8824.17 
Thanks to both of you.
I'm currently runnin as admin, and its working fine.

I will try what Anton suggested too.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All