V4 beta Nov-18-2017 available now  1-20  21-40  41-60  …  121-137

Next
 From:  Michael Gibson
8682.1 
A new v4 beta (version Nov-18-2017) is now available for download here: http://moi3d.com/beta.htm , also linked to from the download page on the main web site.

Bug fixes:

Fix for the frozen UI bug when restoring a maximized main window from a minimized or hidden state. Please let me know if you see it again.

Fix Mac deployment issue that was preventing things from working on OS X 10.8 and 10.9, MoI should run ok there now.

Fix font name bug where MoI V4 would overwrite the UI font name property that V3 uses in moi.ini and so the V3 UI font changed after you ran V4. They should now stay separate.

Fix bug where dropdown controls in commands wouldn't reinitialize to their last used value. Reported by bemfarmer in the forum here:
http://moi3d.com/forum/index.php?webtag=MOI&msg=8675.204

Fix construction line snapping bug reported in the forum by Moujiik here:
http://moi3d.com/forum/index.php?webtag=MOI&msg=8675.119


Not a whole lot of changes, normally I would have waited until a bit more were batched up but the frozen UI bug was pretty significant so I wanted to try and nail that one down soon.


Thanks,
- Michael

EDITED: 19 Nov by MICHAEL GIBSON

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mkdm
8682.2 In reply to 8682.1 
Hi Michael.

Thanks a lot for this "fast" fix :)

Now, I'm going to test it.

but, just one question before I install it.

1) Must I uninstall the previous version before installing the new one ?

2) On the first V4 beta I copied all the scripts/plugins of the V3 just in order to test them.
If I install this new beta will I lose all these files and i have to copy them back ?

And finally a side note.
I'm noticing that downloading the beta from the URL you provided is very very slow,
and this is not due to my internet connection because it's pretty fast.

Thanks. I stay tuned.

Ciao!

- Marco (mkdm)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8682.3 In reply to 8682.2 
Hi Marco, thanks for testing it!

Each beta release installs into its own separate folder by default, so this one will install to c:\Program Files\MoI 4.0 beta Nov-18-2017 . You don't have to uninstall the previous one.

re: copying files - the new beta will have its own commands folder so anything you did to customize the previous beta won't be in the new one you'll have to copy those files over into it same as you did for the previous one.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mkdm
8682.4 In reply to 8682.3 
Freezing problems completely gone for me :)
Thanks a lot.

ASAP I'm going to continue the beta testing in general.

We'll catch up.

Ciao Michael.

- Marco (mkdm)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Mip (VINC)
8682.5 In reply to 8682.1 
Hi Michael,

On Nov 18 version, with OS 10.9.5, after a click to expand the application to full screen (top right corner of window), when I move to the left to enter in MoI's drawing space (using either the trackpad or a mouse), MoI window slides to the right side of the screen and hides immediately.
I have to double click on the application icon in the Dock to make it reappear.
Then Moi's window stays on screen but, randomly, it will hide again, sliding to the right after some movement from the mouse or trackpad.
I checked the trackpad settings and no sliding gesture is activated.

Otherwise, the commands are working well.

Thanks,

Michel
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bemfarmer
8682.6 
Windows 7
(With previously addition of nonupdated customui and nonupdated nodeeditor, and CommandBar Mod.)

Installed V4_18, leaving V4_12 installed.
In V4_18, saved ui/CommandBar.htm, and copied modded CommandBar file from V4_12. (Modded for customui.)
Copied ui/customui to V4_18.
Tried to copy ui/nodeeditor, but failed to do so. Administrator setting may interfere with copying. Mine are a bit relaxed, permitting copying, but making it harder.
(Later copied ui/nodeeditor.) (Folder copied to, must not be open, I think.)
Copied all of the _scripts.js and _scripts.htm to Command folder. (Command folder must not be open)
Used Windows Control Panel to uninstall V4_12.
V4_12 is now gone, except for _scripts, ui/customui, and ui/nodeeditor, and previously saved CommandBarSaved file(s).

- Brian

ps Not sure if I need to locate an old V3 file to revert the fonts?

(Michael, please delete post if it is incorrect, or too confusing... :-)

Note, nodeeditor 0.97 now has menu icons...

EDITED: 19 Nov by BEMFARMER

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Frenchy Pilou (PILOU)
8682.7 
Bravo!
The frightening freezing Moi / Forum / Moi seems definitly disapeared! :) (Windows 10)



I will return for the "Extrude" keeps "Set Dir" when the new functions come back after the stabilization's version! :)

EDITED: 19 Nov by PILOU

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  agonyii
8682.8 In reply to 8682.6 


Hi,

I managed to copy paste all my styles and icons from the previous version. I still wonder how to control/change color of the text for corresponding window titles? I am also getting some strange numbers under?

I would also like to know how to keep my panels in the sidebar open at all time - when Moi starts up. I know it's not related to the startup.3dm or moi.ini file. As that info is not saved there where is it then?

I appreciate it!
Thanks a lot!
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Martin (MARTIN3D)
8682.9 In reply to 8682.5 
I normally do not use MoI in full screen mode so I would not have discovered it. I tried to reproduce Mip (VINC)s problem and it is same for me.
It's this full screen button that causes the problems:
Image Attachments:
Size: 6.8 KB, Downloaded: 14 times, Dimensions: 83x82px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8682.10 In reply to 8682.5 
Hi Michel,

> Then Moi's window stays on screen but, randomly, it will hide again, sliding to the right after some
> movement from the mouse or trackpad.
> I checked the trackpad settings and no sliding gesture is activated.

As best I have been able to tell so far this is stuff that the OS is deciding to do on its own, the full screen mode uses something called "spaces", and the sliding is when the OS thinks you're doing a gesture for switching between spaces which by default is done with a 3 finger left/right swipe.

The trackpad setting for it is under Trackpad > "More Gestures" tab > "Swipe between full-screen apps" which by default is on.

I'm still looking into it so I'm not totally sure yet but I've seen reports of other apps doing this "run off the screen" thing when using full screen mode and so it's seeming likely to be an OS "feature".

If you hold down the Option key while you click the green maximize button or double click on the title bar you'll get the old style maximize behavior instead of the full screen one.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  eric (ERICCLOUGH)
8682.11 In reply to 8682.1 
Yes, Michael
Thanks for the incredibly fast fix.
You seem to manage to create minor miracles almost instantaneously and more major ones overnight.
I hope this whole process is rewarding for you.
eric
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8682.12 In reply to 8682.11 
Thanks eric! Yes, it's definitely rewarding to be back to doing work that can actually be used by people. It was a pretty long slog there just rewriting and porting stuff to v4. There is still a little bit left to do but not much. Then I'll be able to work on some brand new features which will be nice.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8682.13 In reply to 8682.7 
@Pilou,

> Bravo!
> The frightening freezing Moi / Forum / Moi seems definitly disapeared! :) (Windows 10)

Great! I'm glad that was the same thing. You should be able to go back to multitasking now! :)

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8682.14 In reply to 8682.8 
Hi agonyii,

re:
> I still wonder how to control/change color of the text for corresponding window titles? I
> am also getting some strange numbers under?

At the moment there isn't any way to change those colors. That's just temporary though until I'm able to work on text display inside of the viewport.

The numbers are the amount of time the last draw in the viewport took in milliseconds. That will stay on for a few releases here to make it easier to compare performance between versions.


> I would also like to know how to keep my panels in the sidebar open at all time

There currently isn't any way set up to control which things in the scene browser are expanded, but I want to make that saved in .3dm files so it could be handled by the template file.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8682.15 In reply to 8682.6 
Hi Brian,

re:
> V4_12 is now gone, except for _scripts, ui/customui, and ui/nodeeditor, and previously saved
> CommandBarSaved file(s).

Yup when you uninstall the uninstaller won't delete any files that it the installer didn't put there itself, that's to avoid the possibility of it deleting any user data files you created there. So anything you put in there yourself you'll also have to delete yourself after the uninstall.


> ps Not sure if I need to locate an old V3 file to revert the fonts?

To fix V3's font open up moi.ini by using Options > General > "Edit .ini file" button, and inside there find the line that says UIFontName=Open Sans and delete it. Then V3 should go back to using its default font and v4 won't interfere with it anymore.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Max Smirnov (SMIRNOV)
8682.16 
Hi Michael

Thank you for a new version.
I tested both windows and mac versions with windows7 64 and MacOS High Sierra 10.13.1.
I noticed a following problems:

Win+Mac:
1. factory.setInput function stops with "Invalid function argument" error when an argument type is wrong. In fact it's not a MoI problem, but (if I understand clearly) v3 in this case just set input to null and don't stop a script.
I found this errors in two or three my scripts and successfully fixed it. But it can cause a potential problems with other old scripts.
Example:
code:
var f=moi.command.createFactory("loft"); f.setInput(1, ""); moi.ui.alert("Test passed");


2. moi.geometryDatabase.findstyle function returns a wrong data when it creates a new style.
code:
var t=moi.geometryDatabase.findstyle("test", true); moi.ui.alert(typeof(t)); moi.ui.alert(t.index);


Mac only:
3. Something wrong with moi.command.getOption function. I can't read data from moi.ini
Example:
code:
moi.ui.alert(JSON.stringify(moi.command.getOption('LightingOptions', true)));

Win version returns a correct data.

4. Interactive scripts perfarmance problem. MoI v4 18.11 works much faster than with 13.11, but still slower than MoI v3/4(Win) and v3.1(Mac).
You can check it with my SpherePoints+ script. http://moi.maxsm.net/item/2

5. I noticed a rare Orientation Picker bug. Unfortunately I don't know how to reproduce it.

P.S. I tested toNativePath and toScriptPath functions with CustomUI (Mac). Everything is good. Object Library now can correctly create, rename, delete an objects and a preview files in ~/Library/Application Support/Moi/Objects directory. Unfortunately I can't find a way to show previews in Moi html windows. Neither native nor script paths doesn't work.
Image Attachments:
Size: 201 KB, Downloaded: 19 times, Dimensions: 708x479px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Mip (VINC)
8682.17 In reply to 8682.10 
Hi Michael,

I had already unchecked off all the "More Gesture options" of the trackball
and also experimented with a mouse to be sure it was really related to the fact of entering into the drawing space and not a trackpad reaction.

I also went into Mission Control and tried the Space options (and relogged) without success.
It doesn't trigger the sliding when the pointer stays in MoI's command or tools area but, as soon as the pointer gets in the drawing area it slides.

As Martin wrote, it's not a big thing as I also rarely get into full full screen with my apps.
It's just something I noticed while testing the freezing reported by other users.

Thanks,

Michel
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8682.18 In reply to 8682.16 
Hi Max, thanks for reporting these issues, I'll be digging into them in a bit here.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8682.19 In reply to 8682.17 
Hi Michel,

> It doesn't trigger the sliding when the pointer stays in MoI's command or tools area but,
> as soon as the pointer gets in the drawing area it slides.

Thanks for figuring out this additional detail, I can repeat it more consistently now over here as well.

That will let me try a few things like temporarily disable mouse move handling on viewports and see if that has any effect.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Finema
8682.20 
Hi Michael,
I've tested new v4 beta (version Nov-18-2017) on Mac OS 10.13.1 and the bug is always here.
Open MoI
Draw anything
Hide MoI (command H)
Go back to Moi
Choose a draw tool
Clic on scene > the tool freeze and Panel Pick stay empty........
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
Show messages:  1-20  21-40  41-60  61-80  …  121-137