SWEEP DISJOINT

Next
 From:  AlexPolo
8502.1 
Hi Just trying to run a sweep in MOI comes out disjointed 2 ends on 1 rail. No problem in RHINO any advice welcome.





  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bemfarmer
8502.2 In reply to 8502.1 
Hi Alex,
Sweep with large and small end triangles, along central polyline, creates the "missing" corners.

Constructing a second polyline rail along the bottom, and sweep end triangles with both polyline rails seems to work as desired.

- Brian
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  BurrMan
8502.3 In reply to 8502.1 
You're going to have to use 2 rails instead.



We just got mitering a few builds back. Maybe look for an improvement when dev starts up again.
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
8502.4 In reply to 8502.1 
Hi Alex, currently MoI will only attempt to do mitering on a one rail sweep if you're using 1 profile.

Multiple profiles is a pretty different case because with the profile curves constantly changing in shape, the miter is not going to be a planar cut at the juncture point even when the path is a polyline. In the single profile case, with a polyline path the miters are planar.

I was able to tune up MoI's mitering method so your case will work in the next release though, thanks for reporting it.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All