Shortcuts get lost

Next
 From:  agonyii
8477.1 
After some more time inside the app, I have noticed I am losing my predefined shortcuts. I cannot yet find a culprit of that bug, I can only suspect using keys "`" and "/" resets what I have defined as custom. When that happens shortcuts binded to these keys get lost. Sometimes some more but still not all of them.

I am on Windows 10 where I also switch between "English" and "Croatian" keyboard setup. These characters are binded to different keyboard keys if I am using a different language setup so that could be the cause of the problem too. I am not really sure but running multiple sessions at the same time could also be related to the problem. Even though I always make sure they all start with the same .ini file it's still happening.

If anyone has some ideas thanks for the help!
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
8477.2 In reply to 8477.1 
Hi agonyii, it's probably the multiple open sessions - MoI will write the current instance's settings out to the moi.ini file when MoI exits. But if you have 2 instances open and your new shortcut is set up on one of them, if you exit the instance that doesn't have the new shortcuts set in it last, your shortcuts can get overwritten.

So when you're setting up a new shortcut, exit any other running instances first, and exit that instance of MoI before starting any others.

I've tried to think of a good way to avoid that from happening by making all running instances change when you modify a setting, but it's a rather complex thing to set up.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  agonyii
8477.3 
Hi Michael,

that's the first thing I though myself but I don't think it is. As I said, I did some tests prior. I have configured and closed Moi to start fresh if I was going to use multiple sessions. It works fine most of the time but after some longer period looks like .ini still gets corrupted. I did not setup any new shortcut. I guess that's quite possible considering Moi is at least doing reordering of shortcuts by 'ABC' when the app gets closed.

I appreciate the help in any case!

EDITED: 18 Jun by AGONYII

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
8477.4 In reply to 8477.3 
Hi agonyii, is it possible you have any restrictive permissions set on the folder where MoI is trying to write moi.ini to? Or maybe a virus checker might be doing something?

MoI stores shortcuts in memory in alphabetical order, so that's how they'll get written out at exit time.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All