OS X El Capitan with MOI  1-20  21-23

Next
 From:  jaffy64
7650.1 
Hi Everyone,

OS X El Capitan don't work with MOI because X11 is no longer included with OS X, but X11 server and client libraries for OS X are available from the XQuartz project: http://xquartz.macosforge.org. You should use the latest available version of Quartz.

So for now with the new update MOI is not working. So don't update before finding solution.

Have a amazing day;)



  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  javier (JAVIERMARTINEZ)
7650.2 In reply to 7650.1 
Hi!

I've installed the last version of XQuartz and is not working for me.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  jaffy64
7650.3 In reply to 7650.2 
It is working now with XQuartz
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7650.4 In reply to 7650.2 
Hi javier,

re:
> I've installed the last version of XQuartz and is not working for me.

There are 2 steps you need to do - one is to install the latest XQuartz.

Then the second thing you have to do is alter a setting in MoI to make it use the system installed XQuartz rather than the bundled one.

If you only have installed XQuartz and did not alter the setting you won't be able to run until you also do that second step.

Please follow the instructions from here:
http://moi3d.com/forum/index.php?webtag=MOI&msg=6967.4

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  phlatt5th (P5TH)
7650.5 In reply to 7650.4 
Hello, I followed the link and am able to run Moi. However it is now called X11 and more importantly only the right window opens in full screen mode sucessfully either using the shortcut/script for full screen or activating the cursor in the appropriate window in the bottom left.
I may be alone but would appreciate any suggestions or thoughts that may help.
Thanks in advance.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7650.6 In reply to 7650.5 
Hi phlatt5th,

> However it is now called X11

Yes this is unfortunately a side effect of using the system installed XQuartz and there isn't any way to avoid that currently. This won't get any better until MoI v4.


> and more importantly only the right window opens in full screen mode sucessfully either
> using the shortcut/script for full screen or activating the cursor in the appropriate window
> in the bottom left.

Could you clarify what you mean by "only the right window" - do you mean only the 3D or Right viewports (the viewports on the right-hand side of the split mode viewport layout) can be set to be maximized views?

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  YPE (SZ6VQG)
7650.7 
Hi Michael, let me chime in here...

I have added a few screenshots of the behaviour I am seeing:

- screenshot "example 1" shows the overview of all 4 viewports
- example 2 shows what happens when you press the spacebar when the mouse focus is in viewport 1
- example 3 shows what happens when you press the spacebar when the mouse focus is in viewport 3
- example 4 shows what happens when you press the spacebar when the mouse focus is in viewport 4
- the only viewport that shows the expected behaviour is viewport 2 (I did not add a screenshot of that one).

I hope this helps in clarifying this issue.

Yves
Image Attachments:
Size: 1.1 MB, Downloaded: 31 times, Dimensions: 1920x1133px
Size: 982.6 KB, Downloaded: 13 times, Dimensions: 1920x1133px
Size: 711.9 KB, Downloaded: 16 times, Dimensions: 1920x1133px
Size: 773.3 KB, Downloaded: 17 times, Dimensions: 1920x1133px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  phlatt5th (P5TH)
7650.8 In reply to 7650.6 
Hi Michael,
Thanks for getting back to me. I mean only the Right viewport maximizes and works as expected when triggered by shortcut or menu icon.












  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7650.9 In reply to 7650.8 
Hi phlatt5th and Yves, thanks for showing me what you are seeing. It looks like some problem with child window z-ordering or hiding.

Do you see any change if you resize the main window after switching the view mode?

Another different thing you can try is to disable the new "rootless" / System Integrity Protection system mechanism that is apparently preventing the bundled XQuartz from running and then change the settings in MoI wineskin back to their original settings.

For the MoI wineskin settings, undo the checkbox modifications that were listed here: http://moi3d.com/forum/index.php?webtag=MOI&msg=6967.4

To disable rootless follow these steps:

1. Restart the computer, while booting hold down Command-R to boot into recovery mode.
2. Once booted, navigate to the "Utilities > Terminal" in the top menu bar.
3. Type  csrutil disable  in the terminal window and hit the return key.
4. From the Apple system menu select "Restart" to reboot the machine and System Integrity Protection will now be disabled.

If that does not help then to reenable System Integrity Protection follow the steps above, except use the  csrutil enable  command for step 3.

(Steps copied from https://www.quora.com/How-do-I-turn-off-the-rootless-in-OS-X-El-Capitan-10-11)


Does that work any better?

- Michael

EDITED: 2 Oct 2015 by MICHAEL GIBSON

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  phlatt5th (P5TH)
7650.10 In reply to 7650.9 
Hi Michael, tried the revert Wineskin and instructions to disable "rootless" in terminal.
Window behavior unchanged.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7650.11 In reply to 7650.10 
Hi phlatt5th, thanks for trying that. Can you double check the settings in Wineskin (in the Wineskin "Advanced" dialog under Options tab) - the second to last checkbox for "Force use of wrappers quartz-wm ..." should be checked, while the very last one for "Force use of system installed XQuartz ..." should be unchecked.

Is that what you've got?

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  phlatt5th (P5TH)
7650.12 In reply to 7650.11 
Hi Michael, when the last one is unchecked it does not launch, see attached screenshot.
Thanks.



  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7650.13 In reply to 7650.12 
Hi phlatt5th,

re:
> Hi Michael, when the last one is unchecked it does not launch, see attached screenshot.

And that's with "rootless" turned off from a recovery boot?

I'm getting a little confused about what steps you have taken, because above you wrote:


> Hi Michael, tried the revert Wineskin and instructions to disable "rootless" in terminal.
> Window behavior unchanged.

I thought that meant that you were able to launch MoI once the last checkbox was unchecked...

I guess I'll have to get an El Capitan setup over here so I can test it.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Finema
7650.14 In reply to 7650.13 
Hi Michael,
rootless turn off on my mac
in terminal and in recovery mode, i've wrote : csrutil disable
the last checkbox is unchecked
It's OK and MoI launch it perfectly BUT the window fullscreen display is damaged again. Only the Right view is OK.
Image Attachments:
Size: 253.5 KB, Downloaded: 18 times, Dimensions: 1713x1174px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7650.15 In reply to 7650.14 
Hi Finema - thanks for testing that. I've got an El Capitan installation set up over here now and I'm able to repeat the same problem. I will look into releasing a new 3.1 version of MoI to fix the viewport maximizing problem so that MoI will then run ok on El Capitan when rootless is disabled.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Finema
7650.16 In reply to 7650.15 
Ok
thanks Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7650.17 In reply to 7650.16 
Ok, looks like Wineskin has just been updated to work ok on El Capitan now, so I think I will be able to make a new MoI 3.1 release that should work on El Capitan directly, without needing to turn off rootless or install XQuartz separately.

I'll probably be able to get that set up tomorrow.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Finema
7650.18 In reply to 7650.17 
great !
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  phlatt5th (P5TH)
7650.19 In reply to 7650.18 
Excellent, thanks Michael,
In researching permanently disabling "rootless" the possibility of leaving the system vulnerable felt uncomfortable.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  niko (NICKP100)
7650.20 
Thank you Michael that's great
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
Show messages:  1-20  21-23