Moi STLs contain self-intersecting edges ( Teeny bug report ) All  1-3  4-6

Previous
Next
 From:  Michael Gibson
733.4 In reply to 733.3 
Hi Crusoe - there are a couple of settings you can mess with that can help to avoid long skinny triangles.

Expand the Meshing options dialog to the detailed options by clicking on the little down arrow.

There are 2 settings here that can help - the first one is "Divide larger than". You can enter a distance here and any "surface quad" that has an edge longer than that distance will get subdivided. "Surface quad" is one of the stages in the meshing - first surfaces are divided into quads, then n-gons are formed where there are trimming curves on the surface, and when doing triangles the n-gons will be triangulated for the final STL result.

So for instance if you have some long skinny triangles you might try entering a distance of 2.0 there - that will cause polygons longer than 2.0 units in size to be diced up which can help make them more regular sized.


The other settings that can help is "Aspect ratio limit". This is also focused on surface quads, except instead of a distance it is a ratio of long side to short side. So for instance if you enter 2.0 in for "Aspect ratio limit", it will divide any quad that has one side more than twice as long as the other. This one is probably actually a little easier to try than the other one since it isn't scale dependent.


Usually manipulating those settings can eliminate the creation of long skinnys. I'd like to do some stuff in the future to try and automatically detect and eliminate them but it isn't very easy to add it right now because sometimes I can't tell if there are going to be long skinnys until right at the end of the whole process.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Crusoe the Painter (CRUSOE)
733.5 In reply to 733.4 
Actually, those don't do much. The longer tris just get smaller, but still very very skinny. You have to zoom WAY in to see that they have any thickness at all. There needs to be some kind of 'annealing' feature that takes skinny triangles and collapses them down in some fashion. This is probably most important along the trim curves, where a lot of skinny tris can be created.

It's a minor gotcha. The meshes are already pretty clean.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
733.6 In reply to 733.5 
Hi Crusoe, well even though it is minor I'd like to check it out and see if I can tweak things to make it better...

Can you possibly send me the model? Just the surfaces that have the long skinnys and possibly the adjacent pieces to those surfaces. If you'd like to keep it private you can e-mail it to me at moi@moi3d.com

There is already some stuff in place that tries to avoid creating long skinny triangles during the triangulation phase, but if I have some examples where long skinnys are being generated I might be able to tune that up a bit to make that work better.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
 
Show messages: All  1-3  4-6