Tolerance issue?

Next
 From:  Dan (MONTAGMAN)
7158.1 
Hi again,

I am trying to generate a rib by using an intersection plane. When I zoom in after doing the intersection, it appears that the intersection was not completely accurate, and the resulting curve is somewhat taller than the original part (see the attached images and file). I don't think it is just a display issue, because creating a planar surface out of the intersection and then re-intersecting that surface with the original part again results in some additional curves that weren't there in the original intersection. Is this a tolerance issue, and is there any way to fix it? The difference is small enough that I wouldn't normally worry about it, but it can make later work a pain because there end up being multiple snap points that should really line up on top of each other.

Dan
Attachments:

Image Attachments:
Size: 119.5 KB, Downloaded: 11 times, Dimensions: 1150x777px
Size: 32.4 KB, Downloaded: 15 times, Dimensions: 1152x776px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
7158.2 In reply to 7158.1 
Hi Dan, I'll need to look into it some more but it looks like it might be that doing Construct > Curve > Isect is using a somewhat looser tolerance than some other operations.

If I select your main part and then run boolean difference and use the other part as the cutting object, the resulting cut up pieces seem to have better accuracy so try using boolean difference and then extract out the edge curves from that to see if it gives you a better result.

I'll need to do some additional investigation to figure out why generating intersection curves is giving a slightly different result.

You have some fairly small features on that part, like the small edge on the back side is 0.0083 units in length. The booleans incorporate some automatic tolerance tightening that tightens down the tolerance when it sees that the objects involved have some small edges in them, it's possible that is what makes the boolean more accurate in this case then the other intersection curve generation mechanism.

Another thing you can try is to scale things up by 10 times in size (select all, run Transform > Scale, type in 0 enter to specify 0,0,0 as the scale origin and then type in 10 enter to specify scale factor of 10x), it seems the the intersection curve generated by Construct > Curve > Isect is more accurate for the slightly larger object, the standard tolerance is tighter in relation to the object when you do that.

I can see about adding in the automatic tolerance tightening for small features that the booleans use into Construct > Curve > Isect as well for v4.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Dan (MONTAGMAN)
7158.3 In reply to 7158.2 
Thanks, I'll try those tricks for now.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All