UV generation & OBJs

Next
 From:  paulrus
5836.1 
I think I've had this issue before, but now it's becoming a bit more of a problem.

When MOI (Mar 17 beta) exports OBJs, it creates UVs that apparently are outside of the standard 0,1 range. So when I try to import the OBJ into 3DCoat, it complains and will occasionally crash. The exact error is "The square of UV set is too big. It may mean that UV set is incorrect or tiled too much. It may lead to long loading time or crash because of lack of memory. We recommend you use auto-mapping and then use UV tools to create correct UV set."

With Softimage 2014, I can't import many OBJs exported from MOI because it crashes Softimage immediately. The workaround is to use LWO's and PointOven instead.

I don't know if the Softimage crash is related to the UVs or not.

Is there a way to export OBJs without any surfaces or UVs attached?

Thanks,

Paul
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5836.2 In reply to 5836.1 
Hi Paul, that's odd - MoI should only be exporting UV coordinates within the 0 to 1 range, but every surface in the model overlaps on to the same 0 to 1 square so they all share the same UV area rather than each piece having its own separate little partitioned island.

What happens if you export just a simple single box, do 3DCoat and Softimage 2014 have problems with that as well or is it only with some particular model? If it's with one particular model can you please send the 3DM model file and the generated OBJ file to me at moi@moi3d.com so I can take a look?

I guess probably these programs have become sensitive to having many polygons sharing the same UV area.


It is possible to disable writing UV coordinates with OBJ export by a setting in moi.ini - go to Options > General and push the "Edit .ini file" button near the bottom. Go to the [OBJ Export] section and there is a setting there for WriteTextureCoordinates=y - change that to be =n like this:

[OBJ Export]
<....>
WriteTextureCoordinates=n



You can also disable writing materials (what I think you're calling surfaces), under Options > Import/Export > OBJ options > "Write material assignments".


- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bisenberger
5836.3 In reply to 5836.2 
Hi Michael,
I have the same issue when importing a MoI .lwo file into 3D-Coat.
MoI Version 3.0 Beta Mar-17-2013.

I tried a box in .lwo and .obj format with the same results.



The attached image shows the MoI UV's after import.

EDITED: 21 Apr 2013 by BISENBERGER


Image Attachments:
Size: 299.4 KB, Downloaded: 28 times, Dimensions: 1756x471px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5836.4 In reply to 5836.3 
Hi bisenberger,

> The attached image shows the MoI UV's after import.

It sounds like it does actually import though, it just shows that message first?

Since 3D Coat has become more sensitive to having problems with certain UV structures, you may want to disable writing UV coordinates out from MoI and instead create the UV coordinates after the import.

To disable writing UV coordinates out from MoI, open up the moi.ini file by going to Options > General and push the "Edit .ini file" button near the bottom.

For OBJ format, find the [OBJ Export] section and set:

[OBJ Export]
<....>
WriteTextureCoordinates=n


For LWO format, find the [LWO] section and set:

[LWO]
<....>
WriteTextureCoordinates=n




With MoI's built in UV coordinate generation turned off it should avoid that warning message when you then import into 3D Coat after that I would think.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  bisenberger
5836.5 
Hi Michael,
Yep, it looks like 3D-Coat has become sensitive in this regard. No problems opening the .obj or .lwo with modo.
Changed the settings in the .ini as you outlined and no more message. 3D-Coat now defaults to Auto-mapping when I open it, Super cool!
Thanks,
Bill

EDITED: 21 Apr 2013 by BISENBERGER

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All