10.8.2 Export LWO on large model = crash

Next
 From:  Samuel Zeller
5515.1 
It start meshing but crash halfway :(

I can't send the 3DM publicly but maybe Michael I can send it to you in PM so you can check why it crash ?
-- shapenoid.com
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Samuel Zeller
5515.2 
Here's a small part of the model that crash when exporting in .LWO

https://dl.dropbox.com/u/44982094/SWAN%20poignee.3dm

Running latest beta (V3) with modified Xquartz + osx 10.8.2
-- shapenoid.com
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  coi (MARCO)
5515.3 In reply to 5515.2 
..instant crash, when trying to mesh.


  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bemfarmer
5515.4 In reply to 5515.2 
The .lwo did not like the Knob at the bottom left.

The rest of the .3dm uploaded model exported ok as .lwo, in sections.

There is also a little square "plane" section. (?)
Image Attachments:
Size: 44.8 KB, Downloaded: 11 times, Dimensions: 245x333px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Samuel Zeller
5515.5 In reply to 5515.4 
Yeah I basically cleaned a dwg file converted to .sat and imported to MoI that's why there's a little square
-- shapenoid.com
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  blowlamp
5515.6 
I tried saving as a .sat file and immediately loading back in and I *think* it fixed the crash problem.
It might be worth a try anyway.


Martin (2).
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5515.7 In reply to 5515.1 
Hi DesuDeus, thanks for getting it narrowed down to one particular smaller piece, I'm investigating the crash now.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5515.8 In reply to 5515.1 
Hi DesuDeus, there's a tiny squashed degenerate edge right in the "pole" area of the knob, and the mesher is getting screwed up trying to deal with that.

I've attached here a reconstructed version of the knob that has that fixed, if you delete the little knob in your original object and replace it with this one you should then be able to export ok.

That should hopefully get you unblocked and get your export working for now while I continue to work on fixing the bug for the next release.

- Michael
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
5515.9 In reply to 5515.1 
Hi DesuDeus, I've got the bug fixed for the next release. It was a bug when handling a degenerate totally squashed down edge trying to use it as the boundary of an interior hole of the surface, when the degenerate edge was located right at the outer edge area of the main surface. It crashed when trying to divide the surface to "break" the hole.

Thanks for reporting the crash and for sending the file to test with, that helps a whole lot to have the file to work with.

For the current release if you just delete that little knob at the bottom and import the new version I posted above that should allow you to export out with the current version ok.

Thanks, -Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All