won't run on osx 10.8.2

Next
 From:  sokwanho
5414.1 
Just updated my macbook to osx 10.8.2 and Moi V2.51 and V3 won't launch anymore. is there an update coming soon? i am in the middle of a project and need it up and running asap....please help!
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bemfarmer
5414.2 In reply to 5414.1 
So 10.8.2 came out today?

EDITED: 19 Sep 2012 by BEMFARMER

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  sokwanho
5414.3 
Just to clarify the problem, when MoI lanuched, the only thing i can see is the top menu bar with only 3 selections ' moi v2.51, window, Help'....the interface won't launch. And the software won't quit either, i had to force quit.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  coi (MARCO)
5414.4 In reply to 5414.3 
there seems to be some troubles with wine/winskin and 10.8.2.

http://wineskin.urgesoftware.com/tiki-view_blog_post.php?postId=61

so best bet would be to downgrade/not to upgrade, til further notice

EDITED: 20 Sep 2012 by MARCO

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  sokwanho
5414.5 
but downgrading osx needs a clean installation right? that's too much trouble. I really enjoy using Moi, but this situation is making the software unreliable on the mac. is this going to change anytime soon? is wineskin usually pretty stable ?

On a side note, thank you Michael for putting out such a great software! it is so much fun to use.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5414.6 In reply to 5414.5 
Hi sokwanho, yeah right now it looks like there is some change in 10.8.2 that breaks MoI.


> I really enjoy using Moi, but this situation is making the
> software unreliable on the mac.

It seems that Apple has been making a lot of changes in OSX recently, that seems to be a big part of the instability.


> is this going to change anytime soon?

I don't know, I guess you would need to ask Apple. It should be up to them to not introduce too big of changes especially in incremental releases, but it seems that they don't pay much attention to that.


> is wineskin usually pretty stable ?

It seemed like it had been up until OSX 10.8

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  sokwanho
5414.7 
Thank you Michael. Hope apple will fix this soon.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Anadin
5414.8 
Thats a bit of a bugger. Not easy to downgrade OS now :(
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Matelot13
5414.9 
I upgraded to 10.7.5, and get the same error...
Apple is really screwing with its users at the moment...
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5414.10 In reply to 5414.1 
Ok, it looks like you might be able to get things running on 10.8.2 (and also on 10.7.5 where there's a similar problem too) by installing this version of XQuartz: http://xquartz.macosforge.org/trac/wiki/X112.7.4

Then once you have that installed, you will need to tel MoI to use the system version of XQuartz rather than the one included directly inside of MoI. To do that, right click on the MoI app and choose "Show package contents", and inside there run Wineskin.app . On the dialog that comes up go to the settings page and there is a checkbox there that says something like "Use system XQuartz", set that and then hopefully MoI should run after that, please let me know if that works for you.

Next week I should be able to release a new MoI update that will be able to run 10.8.2 without needing to mess with any settings, that will happen on Wednesday at the earliest since I am away on vacation right now.

But hopefully installing XQuartz and modifying that one setting will get things going right now without needing to downgrade the OS.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Message 5414.11 deleted 21 Sep 2012 by SOKWANHO

Previous
Next
 From:  sokwanho
5414.12 
It works! thank you! looking forward to the stable version soon. have a great vacation!
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5414.13 In reply to 5414.12 
That's great news sokwanho, I'm glad that's got you back up and running again!

Please let me know if you see any other problems with it.

Apparently this was a bug in the XQuartz environment that was just hidden and didn't happen to cause any problems until some recent changes in the OpenGL drivers.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Matelot13
5414.14 
Wow, what a speedy answer. Thank you, Michael.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  nonius
5414.15 In reply to 5414.14 
sadly enough it is not working overhere. I regret the osx update so much. :-(

gr.

s.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  coi (MARCO)
5414.16 In reply to 5414.15 
hey nonius..

did you check the new MoI release for OSX?..

http://moi3d.com/forum/index.php?webtag=MOI&msg=5431.1

cheers,
marco
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5414.17 In reply to 5414.15 
Hi sven,

> sadly enough it is not working overhere. I regret the osx update so much. :-(

Which version are you using, are you using the new 2.52 release that Marco has the link to above? That version was released specifically to fix problems with 10.8.2 .

You can get it from here: http://moi3d.com/reinstall.htm

Please let me know if you are still having problems with this most recent 2.52 release.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  nonius
5414.18 In reply to 5414.17 
it took very long to load but it is working, thnx ;-)

life saver

s.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All