Small scale modelling results in miserable OBJ mesh

Next
 From:  TpwUK
5361.1 
Hi all - Decided to do some small scale modelling with an Osram light bulb. The render is OK via IGES, but the resulting mesh even on high density settings struggles with the bulb. As can be seen the base gets broken down into high density, but the bulb don't get the same level of attention.

Martin
Image Attachments:
Size: 247 KB, Downloaded: 111 times, Dimensions: 1804x974px
Size: 181.4 KB, Downloaded: 110 times, Dimensions: 1920x928px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  OSTexo
5361.2 In reply to 5361.1 
Hello,

What I've found useful is to export different parts of the model at different mesh settings and then use the MergeOBJ utility to combine them back into one OBJ to import into a poly modeler / render. This way I can get the mesh detail on specific parts of the model where it is needed.

http://moi3d.com/download/MergeOBJ.exe
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5361.3 In reply to 5361.1 
Hi Martin, the bulb being rougher is because you've set the "Avoid smaller than" parameter in the meshing options there:



That parameter is specifically for making smaller sized things rougher - the way it works is that any polygon that is smaller than the size that you enter in for "Avoid smaller than" will be meshed with a much coarser angle than the regular angle parameter. You can use it to avoid generating higher density details on small sized parts - for example if you enter in a value of 5.0 for "Avoid smaller than" then it will try to avoid putting detail on anything smaller than 5.0 units across. It may divide it just a couple of times if it's highly curved but it will be much rougher.

You can use that if you have some small rounded pieces that are part of a larger model and you're trying to optimize for a lower polygon count and you know that you won't be doing any close-ups on those particular small features.

If you do want detail in small sized features, then you should not set that value at all, since it is about limiting detail.

So set that value to 0 to turn it off, and also maybe put Aspect ratio to 0 as well and then you should see a better quality result.

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  TpwUK
5361.4 In reply to 5361.3 
Hi Michael, thanks for clearing that up for me, I was thinking it meant avoid generating polygon edges smaller than 3 units in size, i did not realise it prevented definition of details on other surfaces. It confused me as it gave lovely meshing to the base but not the bulb.

So many thanks for that one sport ;¬)

Martin
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  TpwUK
5361.5 In reply to 5361.2 
Thanks OSTexo - will be grabbing that one !!

Martin
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All