still problems with "blend"

Next
 From:  mike (MIOHN)
5001.1 
Hi Michael,

with your tips and suggestions I realy made big progress with MOI.

But one problem I still cannot solve.
I'm trying to recreate this blend from the "Majik Tutorial: Audio Speaker"
but so far without any sucess.

Whats the mistake I'm doing here?

thanks again
Mike
Attachments:

Image Attachments:
Size: 79.3 KB, Downloaded: 36 times, Dimensions: 1084x675px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5001.2 In reply to 5001.1 
Hi Mike, take a close look at how Majik's surfaces are set up, notice how his upper surface is all one single surface and it's smooth in these areas here:



Now compare your upper object in those same areas:



Notice how your upper object is not smooth there - you've got sharp creases in those areas and that means that your upper object is not just a single surface, it's made up of multiple faces. That also means that the bottom edge is not just a single edge like it was for Majik's case, instead you've got a bunch of separate split up edges.

Surface blending is limited to only be able to connect a blend between 2 edges, so it helps if you form the upper piece that you are trying to blend to make it just one big smooth surface instead of fragmented into multiple pieces with sharp junctures between them.

Other than making the upper object modeled as one smooth surface the other way you can deal with segmented edges in Blend is to split up the bottom edge into segments as well so that you have matching pairs of segments. You can split an edge up into smaller edges by selecting it and using Edit > Trim and clicking the "Add trim points" button to place points at the spots where you want to cut the edge up.

Hope this helps!

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Marc (TELLIER)
5001.3 
Hi Mike, from the picture my guess would be to make small fillets on your profile curves then use the rebuild function before doing your loft for the top part.

The blend should work after...

Marc
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mike (MIOHN)
5001.4 
Hi Michael,

sorry, I still don't understand!

With the smoother profile it still does not work.

I jointed all parts of the upper profile curves to one curve, made a copy which I
moved more up and then made a loft. So why is this still not "one" object?

But even with segmenting the lower profile curve it still wont blend.

???

sorry for my annoying little problems!

regards
Mike
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mike (MIOHN)
5001.5 
Hi,

even after rebuilding that curve it won't blend.

Can anyone blend this for me, please.
Whatever I try, it does not work.

thanks
MIke
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5001.6 In reply to 5001.4 
Hi mike,

> I jointed all parts of the upper profile curves to one curve,
> made a copy which I moved more up and then made a loft. So
> why is this still not "one" object?

It's because the curves you are lofting are made up of multiple sub-segments. If you select one of them and use Edit > Separate you should see that you can then select different individual segment pieces. When you do a "Join" you don't eliminate segmentation, the segments are still there kind of like a group.

The easiest way to eliminate segmentation from a curve that is made up of multiple smooth segments is to use the Rebuild command on it:
http://moi3d.com/2.0/docs/moi_command_reference10.htm#rebuild

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5001.7 In reply to 5001.5 
Hi Mike,

> even after rebuilding that curve it won't blend.

Your curve was still made up of multiple segments after your rebuild because your segments were not all smooth with one another - it looks like you've got a maybe 5 or 10 degree sharp corner in it in the areas where you can see there were still multiple faces generated:






So you still have not eliminated segmentation in the profile curves before doing a loft.

You can use Rebuild again, with "# of points" mode and turn off "Keep corners" in order to force a smooth curve through those sharp corners that you've got, or you can turn on control points and delete the control point at the sharp juncture to make it smooth.

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mike (MIOHN)
5001.8 
Hi Michael,

as soon as I extrude or loft this curve, the generazed egde gets segmented.
But in that tutorial, there a much sharper corners like in my curve.



regards
MIke
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5001.9 In reply to 5001.8 
Hi Mike,

> as soon as I extrude or loft this curve, the generazed egde gets
> segmented.

Yes - that's because your curve is made up of multiple sub segments that are joined together.

You can see this more clearly if you select that curve and then use Edit > Separate on it.

Give that a try - select that curve that you are lofting or extruding and run Edit > Separate on it.

Now click in empty space to deselect everything, and then go to select the curve again - notice how it separated into 4 separate pieces? That's because your curve is made up of 4 separate segments.

If you use a segmented curve it will in turn generate segmented faces - so for example if you extrude a curve made up of 4 segments, the resulting extrusion will be in 4 separate surfaces.

Since you don't want that to happen, you will need to edit the curve in order to get rid of the segmentation.

See my previous post above for a couple of different ways to do that - (either Rebuild with # of points mode and turn off "keep corners", or delete the control point at the juncture where the segments are meeting).

But it would be easier if you constructed the curve so that it was made of smooth pieces from the start, rather than having a shallow 10 degree or so sharp corner in it.

Anyway - in order for you to go to the next step you have to combine the segments of your curve there together so that your curve is made up of only one single smooth segment rather than multiple segments with small creases between them.


> But in that tutorial, there a much sharper corners like in my curve.

Could you show me where you're referring to here?

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mike (MIOHN)
5001.10 
Hi,

finally I got it!

with a rebuild with 100 points I ended up with a
non-segmented loft and then it worked.

Did'nt thought, that the blend is so limited and
hard to get.

thanks
Mike
Image Attachments:
Size: 115.1 KB, Downloaded: 41 times, Dimensions: 1641x1240px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5001.11 In reply to 5001.8 
Hi Mike, see the attached example for a fixed up curve - here I've used Rebuild with "# of points" mode and turned off "Keep corners" so that it ignores the sharp corner areas and builds one single smooth segment through the whole thing.

By the way, the whole general area of building things surface by surface and doing surface blending is kind of in a more advanced and finicky area of NURBS modeling - really the main area where NURBS are strongest and also most convenient is when you are using the solid modeling part of the toolset instead of the low level surfacing tools. But of course for some kinds of flowing/wavy structures the surfacing toolset is needed.

But you should generally expect a higher learning curve for that style of modeling, and really if you're doing that kind of flowing surface stuff it gets into a gray area where you may be better off doing sub-d modeling for such shapes instead actually.

So anyway, just be aware that you're into the "more finicky" side of NURBS modeling with this general area, solids modeling where you're building things more by booleans and fillets tends to be where NURBS modeling has its best strengths.

- Michael
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
5001.12 In reply to 5001.10 
Hi Mike,

> Did'nt thought, that the blend is so limited and hard to get.

It's something that I want to improve in the future, especially to allow more than one edge on each side of the blend.

But it hasn't been a big priority yet because as I described above, it's basically in a category of more advanced and more difficult type of NURBS modeling.

The initial focus for MoI has been much more on the area where NURBS modeling is actually really strong in, like especially boolean construction and using 2D curves to construct large parts of your model.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mike (MIOHN)
5001.13 
Hi Michael,

its from here:
http://moi3d.com/forum/index.php?webtag=MOI&msg=4561.1

So he built that profile with separate curves, jointed the parts
and rebuilded it.
But as I see now, when I look close, that ist overall smooth.

But what should I do, if I have a model with an open end
and I want to f.e. close that opening when it is not planar?
How should I rebuild the edges of that opening?

MIke
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
5001.14 In reply to 5001.13 
Hi Mike,

> But what should I do, if I have a model with an open end
> and I want to f.e. close that opening when it is not planar?
> How should I rebuild the edges of that opening?

Usually the easiest method is to initially build it with a planar end, and then use a boolean to slice the end off with a 2D curve to make the final non-planar ending shape.

That general strategy of building something that is initially extended further than your final shape and then cutting it off tends to be a good method to use for a lot of situations.

So that would looks something like this:











So note there that you don't initially worry about the final non-planar end shape at first - just get a simple shape constructed first and then put in some details by slicing that shape up.

That's a lot easier approach than if you tried to for example model the non-planar shape all at the beginning and then have to worry about how to fill it in.

With a good NURBS solid modeling workflow some of the edges in your final shape should not be drawn directly by you but instead should be the result of some kinds of boolean operations. It's not good to try and just draw every single edge including 3D warped edges right from the start and then try to patch them in - that's frequently what people with a poly modeling background seem to end up doing though so kind of watch out for that.

- Michael

EDITED: 12 Mar 2012 by MICHAEL GIBSON


  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All