why does "blend" not work here?

Next
 From:  mike (MIOHN)
4993.1 
Hi,

sorry again!

I cannot blend that curves. Why?

I always have problems with differencation of "construction" splines
and "work" splines. Which are which? And which can I delete after f.e. trimming?

And so often I use the "joint/verbinden" command and then
I still can select the individual splines. So they did not joint. I cannot understand that.
I merge and merge and merge and still have single items.

???

regards
MIke
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  coi (MARCO)
4993.2 In reply to 4993.1 
Oi Mike!

You really have to MERGE (this one)

http://moi3d.com/2.0/docs/moi_command_reference10.htm#merge
http://moi3d.com/2.0/docs/moi_command_reference10_German.htm#merge

those edge fragments. JOIN or BOOLEAN MERGE won't do the job here. After that, everything works just fine.

Cheers,
Marco

EDITED: 8 Mar 2012 by MARCO

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Frenchy Pilou (PILOU)
4993.3 In reply to 4993.1 
It's more loft in this case!
And you must join first some bottom lines and some top lines ;)

You can delete construction lines if you think that you don't change in the future the curves generator
---
Pilou
Is beautiful that please without concept!
My Gallery
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bemfarmer
4993.4 In reply to 4993.1 
(I have not re-read the earlier posts.)

Ran Blend on the two red edges, to get the green curve.
Did Sweep of the green curve, with the blue edges as rails.




EDIT: This is not the correct solution.

EDITED: 8 Mar 2012 by BEMFARMER

Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Marc (TELLIER)
4993.5 In reply to 4993.4 
Nice solution Bemfarmer!


Just make sure that you are using the edges of the surface and not the 2d curves. (select surface and then the edges as a sub-selection)
Then hit tab and type: merge, the edges will join themselves.

After merging them you can perform the blend between the two surfaces.

It's easier to hide or delete the overlapping 2d curves in your drawing prior to this operation.

Marc
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mike (MIOHN)
4993.6 
oh thank you!

Thought "join" and "merge" is the same.

Now with real "merge" it works!

thanks
mike
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  bemfarmer
4993.7 In reply to 4993.5 
Finally got merge and blend to work. Found it to be very tricky.
The easiest way to avoid the 2d curves on the outer objects, was to style them all red, and then hide them with the eye selector.
Then select all the surfaces and run merge on them.
Then select center object surface, then one of its edge U shapes, select one of outer U edges, and blend. Repeat for all outer objects.
Image Attachments:
Size: 65.6 KB, Downloaded: 1 time, Dimensions: 221x198px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
4993.8 In reply to 4993.1 
Hi Mike,

> I cannot blend that curves. Why?

It's because of the original curve cutting objects that you've still got sitting there - they are on the exact same spot as the edges and they are getting in the way of selecting the edges - in order to generate a surface blend you've got to select the edge of the surface and not the original curve objects.

The easiest way in this case to be able to get at the edges is to hide all the curve objects - you can do that by going to the Scene Browser, Types section and click on the eye icon for the "Curves" entry there - that will hide all curve objects.


> I always have problems with differencation of "construction" splines
> and "work" splines. Which are which? And which can I delete after
> f.e. trimming?

You can delete or hide the curves you used as the cutting objects after doing a trim. Sometimes it can be convenient to actually move the curves a distance away from the object that is being cut and let them project on to it (just using the projection built into trim, not as a separate project step), then with them some distance away from it they can be easier to select later on.


> And so often I use the "joint/verbinden" command and then
> I still can select the individual splines. So they did not joint.
> I cannot understand that.

Yeah the "Merge" command is different than "Join" - Merge right now only works to combine fragmented edges of a solid together into longer edges, it does not do anything on curve objects although I do want it to work for combining curves in a similar way in the future.

One other tip - in this case if you're going to do a blend later on it can be good to get the curve you are using as a cutting object to be all one single segment so that you will then have the edges that are generated from it also just be one piece after the Trim - you can use the Rebuild command on your segmented cutting curve to do that:
http://moi3d.com/2.0/docs/moi_command_reference10_German.htm#rebuild

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All