Moi meshes in Maxwell Render

Next
 From:  Rich (LOOPCORP)
4083.1 
I think that this is more a problem with Maxwell than Moi but I thought I may as well post here too.

Has anyone else got a successful formula for using Moi3d and Maxwell together. I just can't get it to render cleanly. You can see my problem here:

http://www.loopcorp.com/Miscellany/Moi_Maxwell.jpg

It renders OK in Cinema 4D's native renderer but not Maxwell. I've tried all kinds of settings for the exported mesh - nGons, quads & tri's, tri's only (although it's always meshed to triangles by the time it hits Maxwell anyway) but nothing seems to work.

It's a shame because certain forms really lend themselves to Moi 3d rather than a SubD modeller but as long as I'm rendering in Maxwell it seems I can't use it.

EDITED: 4 Mar 2011 by LOOPCORP

Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
4083.2 In reply to 4083.1 
Hi Rich, it looks like the vertex normal smoothing data is not coming through.

What file format are you using for transferring into Maxwell?

Try using OBJ format and set Output: Quads & Triangles.

Also if there is any checkbox option in Maxwell's importer that says something like "Read vertex normals", make sure that is enabled.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Rich (LOOPCORP)
4083.3 
Looks like I'm going to be using Moi a lot more now! This has been a problem I've come up against for ages and I've seen it mentioned elsewhere too when bringing meshed nurbs files into Maxwell - it was the vertex normals.

FYI, I have been going to Maxwell via Cinema 4d and the import options for obj are limited (scale only) but there is an obj import plug-in called Riptide which has the checkbox for vertex normals. I just used it and the model is now silky smooth.

Thanks Michael, you've given me a great new option in my workflow.

http://www.loopcorp.com/Miscellany/obj_test.jpg

Cheers
Rich
www.loopcorp.com

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
4083.4 In reply to 4083.3 
That's great Rich, I'm glad you've got that solved now!

And yes, you should definitely notice a major improvement in render quality in shading and reflections.

Getting the vertex normals to come through makes a huge difference because they come from the original NURBS model, so when they're used to shade the polygons it makes them have the same shading appearance as the original NURBS surface. If they don't come through then the shading normals are cooked up by averaging the normals of the polygon faces together that share a point in common, but that's not as good as using the original information directly.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  macray
4083.5 In reply to 4083.4 
I just answered that already in the Maxwell forum, but maybe it could be helpful here as well:

Usually I just delete the Normal Tag, adjust the Phong Tag of all objects in Cinema and then everything translates fine to Maxwell and renders as expected.
MoI and Maxwell work really great together with this small workaround.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
4083.6 In reply to 4083.5 
Hi macray,

> Usually I just delete the Normal Tag

But if you do this, don't you lose the accurate vertex normals?

To get the best quality shading without any kind of smoothing artifacts, you want to preserve the vertex normal data that was read in during the transfer from MoI.

The only time you should delete vertex normal data is if you have done some edits on the model like pulling around some points. If you end up using the old vertex normals, it will try to shade it with the previous shading information which will no longer match the new model point structure. That's actually something that would be better for the program to just handle automatically for you though (meaning it should just auto delete vertex normals if you pull some points around). Also some programs may sometimes not transform the vertex normals properly if you rotate or flip the normal directions on objects in some cases like if you're in a particular edit mode, that's a bug that should be reported in those programs so that they can improve their vertex normal handling to work better.

Do you have an example model that you can post where you had to delete the normal tag in order for it to render properly? Was it a case where it did not look correct if you just rendered it immediately or did you run into problems after doing some kind of edits or transforms to the object?

If you can post an example of that it would be helpful for me to see it so I can figure out what is going wrong with it, because under regular circumstances you should try to preserve the normal tag and not delete it. Having the accurate vertex normals come through and used in the final render is a key thing to enable the renders to look totally smooth and be shaded exactly the same as the original NURBS objects, because those vertex normals come from the original surface instead of being created just by averaging polygon faces.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Rich (LOOPCORP)
4083.7 
I don't get a normal tag when I do a standard import of obj to Cinema, only a phong tag. Riptide gave it a normal tag, and it worked like a charm.

Cheers
Rich
www.loopcorp.com

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
4083.8 In reply to 4083.7 
Hi Rich, over here I do get a normal tag when importing just using the standard non-Riptide OBJ importer.

But there is a setting for it, is yours possibly turned off?

Under Cinema4D v10 go to Edit > Preferences > Import/Export > Wavefront Import, and there is a checkbox there for "Import Normals", is yours unchecked?

But you're actually better off using Riptide anyway, because Riptide will read the material definitions so that colors that you have set up with styles in MoI will then come through.

The standard OBJ importer will read the material assignments for which materials each polygon belongs to, but it doesn't read in the actual material color properties.

But as far as I have seen the standard importer is able to import vertex normals if that is enabled.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Rich (LOOPCORP)
4083.9 In reply to 4083.8 
Actually yes, that is checked here too but I still don't get a normal tag that I can delete. I do via Riptide but not the standard importer.

[Edit] Sorry just re-tested that, I was wrong. I do get the normal tag from Moi obj files. I tested a Cinema OBJ which didn't bring normal tags. [Edit]

I remember the advice some time ago was to import LWO rather than OBJ, was that related to this issue?

EDITED: 6 Mar 2011 by LOOPCORP

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
4083.10 In reply to 4083.9 
Hi Rich,

> I remember the advice some time ago was to import
> LWO rather than OBJ, was that related to this issue?

Using LWO instead of OBJ only applied to Modo, not to Cinema4D - for Cinema4D it's always been best to use OBJ format.

Cinema4D's LWO importer does not know how to read vertex normals out of the LWO file, since that's kind of a newish thing for that particular format. Getting normals from LWO format only works with Modo or with the newer versions of LightWave, something like LW 9.6 and up.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  L_AN
4083.11 
Hi Rich, I had the same problem and here is the solution I've found.

In Moi3D best to use OBJ format and set Output: N-gons.

In Cinema:

1. Select maxwell scene object in object manager

2. Selection > Selection filter > Select Tool > Polygon

3. Open Script Manager and execute this script:

CallCommand(1016174); // Remove N-gons
CallCommand(12139); // Points
CallCommand(12112); // Select All
CallCommand(440000042); // Connect
CallCommand(1023133); // #$80Render Render View
CallCommand(12298); // Model
CallCommand(12105); // Undo
CallCommand(12105); // Undo
CallCommand(12105); // Undo

Sorry for my poor English

Regards
L_AN
Image Attachments:
Size: 24.5 KB, Downloaded: 30 times, Dimensions: 600x500px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Rich (LOOPCORP)
4083.12 In reply to 4083.11 
Hi L_AN

Don't apologise for your English, that was fine!

Thanks for the tip. I'll have a look at that too.

Cheers
Rich
www.loopcorp.com

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  macray
4083.13 In reply to 4083.6 
my point is - the normal tags are not recognized in Maxwell and if they attached to the objects there the phong tag is not represented in the Cinema viewport.
So to see how the phong tag is adjusted and how the edges will appear in Maxwell - I get rid of the normal tag and adjust the phong tag. (of course one could check the angle, undo the steps to get the normal tags back and then set tha phong tag again...)
The output is not bad after these steps, just no more normal tags are present.
I don't see another way for this, but it worked for me so far without problems to translate models to Maxwell.

What you see is what you believe - so don't. (from an Amiga500 demo)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
4083.14 In reply to 4083.13 
Hi macray - maybe Rich will chime in with what solution works for him, because earlier in this thread he mentioned that using vertex normals (represented by the normals tag) worked for him going into Maxwell.

How exactly are you going into Maxwell, is there a plug-in that you're using? Maybe there are some settings on the plug-in that you have to enable to make normals be transferred.

... I just did some browsing of the help file for the maxwell C4D plugin here:
http://think.maxwellrender.com/docs/maxwellrender_cinema4d_plugin_manual.pdf

There is an "Ignore Normal tag" checkbox option in the "Maxwell Object Properties" dialog, so make sure that is not set on any object that you're transferring, and also it says:

   "Note that Normal tags will be ignored automatically if the object is not already triangulated; in that case, the normals contained in the tag will not be suitable for rendering the triangulated object and must
instead be regenerated from scratch."

So that would seem to be your problem - try exporting out from MoI with "Output: Triangles only" in order to avoid this limitation of the Maxwell exporter that it ignores normal tags on quads or n-gons.

Once you do that you probably should not have to delete the normal tags or add a phong tag, and you will get the high quality normals used which will give you the best quality.

Also you may want to contact Maxwell support and ask that they remove this limitation in their plug-in that the Normal tag gets ignored unless your object is completely triangulated. Cinema4D's built in renderer is able to use normal tags on n-gons and it would be good if Maxwell's plug-in behaved in the same way and use the internal triangulation instead of actually requiring the entire base object to be triangulated.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Rich (LOOPCORP)
4083.15 In reply to 4083.14 
Hi again

Actually I was having some problems again today and I'm afraid I wasn't quite methodical enough to find exactly what tripped me up but the initial solution from Michael worked well in the end. I can say it seemed to struggle with a model which had some very long, thin triangles on it. I experimented with "aspect ratio" but ended up using "divide longer than" to dice it up a little more. I used Riptide to bring in the normal data and styles came across as very useful poly selection tags (thanks for that tip, Michael).



I also tried a standard OBJ import but that gave me shading errors. I tried the idea of deleting the normal tags and fiddled with the phong tag from 40° down to 1° but I have to say it didn't work for me on this geometry. Likewise I had a go with the script tip from L_AN but unfortunately that really screwed up my model, breaking a lot of the booleaned parts of the logo plaque. I imagine that a lot of these techniques can be dependent on the type of model you are building.

Can I just thank all of you for all the ideas on this problem, hopefully it helped some others too.

Cheers
Rich
www.loopcorp.com


  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
4083.16 In reply to 4083.15 
Hi Rich,

> I can say it seemed to struggle with a model which had some very long, thin triangles on it.

So often times that is also related to vertex normals not coming through.

I was looking at the documentation for the C4D Maxwell plug-in, and it seemed to say that the normal tag was ignored on objects that are not entirely made up of triangles.

So you may need to change the "Output" setting when exporting from MoI to "Output: Triangles only", it looks like you currently have it set to "Output: Quads & Triangles".

Possibly once you have it set to that you may not need to dice up polygons anymore, but if that's something that Maxwell is just generally sensitive to then it still could be necessary.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  PaQ
4083.17 In reply to 4083.16 
An other solution is to bypass any 3d package and import the model in maxwell studio direclty.
It was working really well with normals shading when I try it that way ( after having lot of trouble with MoI model
reexported from 3dsmax or modo ... it has nothing to blame against MoI of course).
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  L_AN
4083.18 
Hi Rich, Michael is right in his description of the situation with Maxwell. With exports in triangulated OBJ format everything must be OK, but working with this in Cinema is horribly (selecting, unwrapping, etc.).
I use n-gons mesh and triangulate it just before hitting render button. The trick is in triangulation without breaking vertex normals. For this I take a few steps:

1. Select imported polygon object(s)

2. Functions > Remove N-gons

3. Select all points

4. Structure > Connect

5. Render Scene

> I also tried a standard OBJ import but that gave me shading errors.

Hm, I have worked well in Cinema 4d R11.532. Of course, "Import normals" checkbox must be set.


Regards
L_AN
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
4083.19 In reply to 4083.18 
Hi L_AN, thanks for those steps on triangulating within C4D without losing normals!

Of course, if it is possible to do that with a few manual steps like that, it seems like it should also be possible for the Maxwell plug-in to do the equivalent thing so that you would not have to worry about this issue at all.

I would recommend contacting Maxwell support and asking them to improve their plugin to remove this problem where their plugin ignores the normal tag on all but triangulated geometry. If they need triangles, there should be some method in C4D that will allow them access to C4D's triangulation which includes the normals. That's what C4D's own built-in renderer does.

Including the normals is a very important thing for any rendering program, so they should never be ignored like that.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All