3dconnexion (spacenavigator)

Next
 From:  necko (NECKO77)
3739.1 
Hi, i have a little prblem with navigation in 3D window with my spacenavigator

My units are mm and when i start to model something small, navigation in 3d window works great (when i create something small, like little speakres 25x10x10 cm)
But when i start to draw door (which is bigger, 140x220 cm) Then i start having problems with zoom in 3d. Its not complex model, just outline of door (8 lines :)), so it is not complex and havy model. It become very very slow to zoom in and out. It works great in other views but in 3d is too slow. Only zoom is 2 slow other movement like tilt, rotate works flawlessly
I open at the same time archicad and it navigates great there no matter what i do. I tryed everything but problems persist.

If i put zoom speed 20 then it works great in 3d but in other views is too FAST !

my 3dconnexion drivers are
relese version 3.11.3
driver version 6.11.1
firmware version 4.04
Spacenavigator
win 7 64 bit
In other aplications i dont have problems
thx

i just discover that if i put my model units from mm to m then zooming is ok, cos my model is scaled down.

EDITED: 26 Aug 2010 by NECKO77

Image Attachments:
Size: 158 KB, Downloaded: 70 times, Dimensions: 930x635px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3739.2 In reply to 3739.1 
Hi necko - when you zoom in it will try to approach the rotation pivot point, so that you can more easily zoom right in to a particular area of interest.

If that rotation pivot point is some distance in front of the point that you actually want to go to, then you can experience that kind of thing that you're describing - it's slowing down because it is trying to come close to that pivot point instead of just running right by it.

When you to a pretty small distance away from the pivot point, then it will stop trying to just approach it and then start to move past it.

So there are a couple of things that you can do to control this.

The first is that you can set the rotation pivot point to the point you are interested in zooming in on, that should make your zoom-in work more predictably. To set the pivot point, use the "Zoom area" button at semi-transparent toolbar at the bottom of a viewport. The center point that you pick for the zoom will become the new rotation pivot point.

Also if you do a view Reset operation, the rotation pivot point will be set to the center of the objects that were zoomed to.

Another thing that you can do is to switch the 3D view into parallel display mode rather than perspective display mode. In parallel display mode zooming works differently, it's done by just a scale factor instead of being sensitive to an eye location point, and so it doesn't have this same kind of issue.

Is it possible that the 3D view that you're using in archicad is a parallel one and not a perspective view? If so then that would be one big reason why it behaves differently.

To set MoI in to parallel view mode, go to Options > View > 3D view projection.

The view mode is saved when you save to a 3DM file. If you want to make a parallel view used when starting up MoI, create a file with the view set to parallel in it and then specify that file as the startup template under Options > General. Then the stuff in that 3DM file will be read in when you start up MoI, you can use that same way to set default styles and other things like that too.


Hope this helps,

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  necko (NECKO77)
3739.3 In reply to 3739.2 
thx for your answer, and expl. how stuf works...

In archicad i have no problem moving around, i even have to slow down all commands to be able to move precise.

In archicad i work in perspective cos its more natural for me (paralel view is a little bit strange, you know what i mean)

I tryed paralel view in Moi and it works like it supose to work, i tryed with the area zoom and you are right about that too :) ( i dont like to work in paralel view, cos its not natural to me)

comparing ARCHICAD navigation and MOI main difference is that ARCHICAD is not locked to anything. Im able to freely fly aroud object or house, or planet dosntmatter what size it is and it works flawlesly in perspective and paralel view.

If you can update this it could be great...but i know that you have important stuff to do.
Thx for your time Michael
Image Attachments:
Size: 231.4 KB, Downloaded: 51 times, Dimensions: 1176x691px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  necko (NECKO77)
3739.4 In reply to 3739.3 
Can you Michel make option when you zoom in or out to go ito space not to rotation pivot point ?
or should i go to 3dconnexion forum and there post whis wish ?
Thx
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3739.5 In reply to 3739.3 
Hi Necko,

> comparing ARCHICAD navigation and MOI main difference
> is that ARCHICAD is not locked to anything. Im able to freely
> fly aroud object or house, or planet dosntmatter what size it
> is and it works flawlesly in perspective and paralel view.

Yes, but that kind of free movement causes a different problem - it makes it so you can no longer stay focused on one particular area of a model that you are working on. Every time you zoom in with that kind of a system the rotation pivot point will move around, so that if you then rotate after your zoom you will not be rotating around the same point.

That means that you can't do something like zoom in on a specific corner of the model and then also rotate around that same corner afterwards.


> Can you Michel make option when you zoom in or out to go
> ito space not to rotation pivot point ?

Yes, it should be possible for me to put in an option for this behavior, I've added it to the wishlist: http://moi3d.com/wiki/wishlist


> or should i go to 3dconnexion forum and there post whis wish ?

No, it's something that is part of MoI's behavior, for how it responds to the zoom events coming from the 3dconnexion device. So it's not something that the 3dconnexion people would be able to adjust themselves.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  necko (NECKO77)
3739.6 In reply to 3739.5 
yes i understand what you saying...


Tip....
i just install blender and there is 3 option of movement

trasform, fly and turntable /easy switchable with button on spacenavigator/

Tranform - moving rotating scaling with 3dmouse selected object

Fly - Fly around - need more skilled user to be able to move around space...nothing is locked, you can roll, tilt, spin at the same time

turntable - is somthing like in moi. When i select object i move around it


so when i press left button on my 3dconnexion device i can switch between these 3.
With that is possible to fly around, select what you need, then go to turntable option, rotate around object

its very functional and now i can easely navigate trough Blender models !

Thx one more time for your time...
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All