Backdrop images

Next
 From:  phunkidude
3553.1 
I am trying to put a 'backdrop' image in my layout to trace over. I've found the image button but it does not seem to do anything. I clicked the origin as one corner and then randomly elsewhere as another corner. Nothing appears but when I click on the Image button again it lists my images.

What gives?

Sean
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3553.2 In reply to 3553.1 
Hi Sean, could you give some more information about the image you are using, like what format it is, and how large it is?

Maybe there is some problem loading it in for some reason.

If you could attach the image here or e-mail it to me at moi@moi3d.com that would let me check it out.


Also could you try loading the attached test image and see if that works?

- Michael
Image Attachments:
Size: 25.1 KB, Downloaded: 20 times, Dimensions: 800x600px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3553.3 In reply to 3553.1 
Hi Sean also maybe let me know what kind of video card you have.

If you have a video card with a very limited amount of video memory on it, it may be possible that you just do not have enough available space for the textures that will hold the images to be created.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  phunkidude
3553.4 In reply to 3553.3 
Michael,
I tried your test image and that did not work either. if I click on the 'Image' button and hover my pointer in the general area, a yellow frame appears which I assume is the image.

My card is:

NVIDIA GeForce GT 120 with 512 MB VRAM

I think I'm doing something wrong.

Sean
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3553.5 In reply to 3553.4 
Hi Sean, are you trying it on a completely new blank scene or are you trying it on a model where the screen is full of stuff?

> if I click on the 'Image' button and hover my pointer in
> the general area, a yellow frame appears which I assume
> is the image.

Yeah, while you are in the Image command when you move the mouse over an image its border will highlight so that you know which one you are going to manipulate if you click down and drag to move it.

By default images are drawn in the background and all geometry is drawn on top of them, since one of their main purposes is to serve as a backdrop to trace over.

But there are options in the Image command to control that, with the "Draw" option, the default is "Draw: Below objects", but you can set it to "Draw: With objects" (the images are drawn same as if they were regular plane objects in the model), or "Draw: Above objects" (the image are drawn as an overlay on top of everything).


If you start with a blank model, setting a background image should work like this:




Here I am running the View > Image command, then clicking the "Add button", and then picking the image file name with the file dialog that pops up (that part is not visible on the screencap) after you push OK on the file dialog you then click a point to pick the starting point and then click a second point for the opposite corner.

If you are doing that but the image is not showing up, you may try going to the nVidia web site and installing the latest drivers they have available there, it could be some problem in your video driver.

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3553.6 In reply to 3553.4 
Hi Sean, also are you possibly running on a virtualized system like Parallels on a Mac?

If so then by default it actually makes a smaller amount of video memory available to the virtualized program.

If you are running under Parallels, try going to the "Virtual machine configuration" options, "Hardware" tab, "Video" section, and move the video memory slider over to the right to make some more video memory available to MoI.

For example see here:
http://download.parallels.com/desktop/v5/docs/en/Parallels_Desktop_Users_Guide/22895.htm

If you are running under something like that, then possibly your current virtual machine settings are leaving MoI kind of starved for video memory so that it is not able to allocate enough texture memory on the card to hold the image.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  mikerogers74
3553.7 In reply to 3553.6 
I get this same problem under Parallels as Michael describes. Unfortunately even when allocating 256mb of ram to the video card the images do not show up. Even using small images (around 300k). I just boot into bootcamp when I need to use images. I've yet to try Vmware Fusion to see if it's the same.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3553.8 In reply to 3553.7 
Hi Mike yeah 256mb of ram available should be plenty to hold an image texture.

Maybe there is some information in MoI's debug log about what particular video card thing is failing.

Could you try this - start up a new session of MoI under Parallels and try to insert an image into it so you get that problem. Then hold down the Ctrl key and click on the "MoI" title text in the upper right corner area of the main MoI window.

That will open up a debug menu, and the first thing on the menu is "Show log" - pick that one and then in the log window you can right-click on the text control and do a "Select all", and then right-click and pick "Copy" to copy the log text to the clipboard to paste in a message here so I can see it.

That could possibly give me a clue as to what Direct3D thing in Parallels is not working right.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  phunkidude
3553.9 
Yep, Parallels is the problem. Parallels defaults to using a built-in video driver. I've asked on the Parallels forum whether it's possible to have a Windows Virtual machine to use 'real' drivers but they're pretty hopeless at helping there so we'll see.

In the meantime I've installed Windows 7 on Bootcamp and Moi3D is displaying backdrop images.

YAY!

Thanks all!
Sean
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All