Blend & fillet won't work.
All  1-2  3-8

Previous
Next
 From:  rodney (RODNEY71)
3534.3 
looks to me like your surfaces simply weren't joined. select the front and the surfaces that connect to the front and run the Join command.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3534.4 In reply to 3534.1 
Hi Dave, yup you'll want to join those individual surfaces together (select them and run Edit > Join) so that they have a shared joined edge between them instead of how they are currently set up as just totally separate objects.

Once you have joined them, you can then select the front planar surface and fillet its edges with a radius of up to about 0.1 units.


> I've also tried using a blend surface after trimming round the
> plane with a rail surface, but can't make that work either.

If you have that version handy could you please post the 3DM file for it as well?

One thing with blend is that you need to select 2 surface edges to make the blend happen. If you have some curve construction geometry still hanging around it can pretty easily happen that the construction curves are sitting right over top of the surface edges and getting in the way of selecting the edges. If that's the case you want to delete or hide the original construction curves so that you can get them out of the way to make it easier to select edges.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Dave (DEEMACSEE)
3534.5 In reply to 3534.4 
Michael et al,

Thanks for the quick replies.

I tried filleting after turning the whole thing into a boolean solid but it didn't work.

I tried again and it did work when I (accidentally) changed the radius value by clicking in free space in the view window and moving the mouse, but when I undid and tried again for a different radius using the virtual keypad it wouldn't work; using the free-space clicking method of changing radius wouldn't work again .

I joined the front three segments before filleting with the front plane as a separate object - didn't work.

I did the same after joining all the elements of the object both with the plane end as a separate object and joined as part of the whole - didn't work.

I ran fillet after joining the three parts of the edge to be filleted - didn't work. I tried filleting a box and a tube (just to see if it was me being thick) and while it worked at the join between the two solids I did notice that when I tried to create a blend surface at the end of the tube after trimming away the edge with a swept circle surface, the tube edge consisted of two separate sections, and attempting to blend between these edges and the remains of the end cap failed.

I can't figure it out. I'm using v1.1. Might that be the problem?
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  DannyT (DANTAS)
3534.6 In reply to 3534.5 
Hi Dave,

I tried this in V1.1 and like Pilou's results the maximum fillet you can get is .22 and it should work, I did have it as a solid.
It works if I pick the body as a whole which fillets all corners or if I just pick the edges at the front and that also works.

-
~Danny~
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3534.7 In reply to 3534.5 
Hi Dave, what Radius values are you entering when you are trying to do the fillet?

Most likely you are using values that are too large, try smaller sized values.

Edge fillets won't work if they don't fit in the available space, and when you have narrow or sharp areas like the front slanted edge of your ship, it doesn't take very much of a radius value to cause a fairly large area of the model to be carved off.

Like Danny mentions, even in version 1.1 values of up to 0.22 should work. More than that and it creates a difficult situation for the filleter to try and resolve the connections between the different fillet pieces.

Here I've created some fillet surfaces with a radius of 0.4 by using surface/surface filleting and manual trimming. Surface/surface filleting is when you select 2 surfaces that are individual separate objects (instead of joined) and run the Fillet command which builds a fillet surface in a somewhat different manner than the edge based one:



You can kind of see there how it is getting difficult for the filleter to figure out how those different fillet pieces should connect up, since the fillet piece between the surfaces that are sharply angled to one another eats up much more space than the other one.

quote:
I tried filleting a box and a tube (just to see if it was me being thick) and while it worked at the join between the two solids I did notice that when I tried to create a blend surface at the end of the tube after trimming away the edge with a swept circle surface, the tube edge consisted of two separate sections, and attempting to blend between these edges and the remains of the end cap failed.


Sorry, it's difficult to follow along your description here - could you please post the 3DM model that contains the things that you are referring to like "the remains of the end cap" ?

It will be a lot easier to understand what you are talking about if I can actually load up the model to look at it.

Blend only works between 2 edges at a time, and if you have a small edge and you want to blend it to some piece of a longer edge you will need to cut up the long edge into smaller segments as well. You can do that by using the Trim command and click the "Add trim points" button when it asks you to select cutting objects, that will allow you to pick points on the edge for where to cut it.

- Michael
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
3534.8 In reply to 3534.5 
Hi Dave, also I tried importing your model into 2 other CAD programs (Rhino and ViaCAD) and both of them also have similar trouble trying to do a radius value of over 0.22 as well, most likely due to the same difficult situation in trying to connect up the different fillet pieces that I showed previously.

If a fillet radius of 0.2 is not large enough for you, I think you will need to use some other technique to build that particular part of the model instead of filleting, like maybe putting in a sweep surface there or something like that.

I've attached one result model that I made by trimming back some space and using Blend, it looks like this:



I started by drawing a curve in on the front planar surface, this is a lot easier in version 2 where you can use the View > CPlane tool to relocate the Top plan view to be looking straight down on that face:



Then I trimmed that front face with that curve:



Then I went into the right-side view and drew in a side cutting profile curve like this:



And then used that to trim those other surfaces:



Then I used Trim to cut up the edges of the planar piece so that they could be matched in pairs for blend like this:



- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
 
Show messages: All  1-2  3-8