Exporting to Blender  1-20  21-24

Next
 From:  d^^b (DAVID)
3343.1 
Hello:

I think that I´m not very skilful when I try to export any object from MoI to Blender.
I usually get bumped or rough areas in my surfaces.
Steps I follow:

Into MoI:

I export the object in *.lwo format.
Output: Triangles only
Weld vertices along edges: unchecked
In Options-->Import/Export--> LWO options: Lightwave

Into Blender:
I use the Blender importer posted here


Well. I don´t know if it´s necesary to have any settings into MoI before exporting, or in Blender after importing.

I put an example, with a screenshots and the 3dm file. If someone can help me.... :-)
This is the surface of a hull I was drawing.
The surface is built by Loft with Loose and 5#points (First doubt. I don´t know if there aren´t points enough)

1.-Export options
2.-Original surface
3.-Control pointd of the surface
4.- Weird result in Blender :-(

EDITED: 23 Feb 2010 by DAVID

Attachments:

Image Attachments:
Size: 741.2 KB, Downloaded: 80 times, Dimensions: 1400x1023px
Size: 516.4 KB, Downloaded: 49 times, Dimensions: 1400x1026px
Size: 574.1 KB, Downloaded: 33 times, Dimensions: 1400x1026px
Size: 192.9 KB, Downloaded: 107 times, Dimensions: 1400x1025px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.2 In reply to 3343.1 
Hi David, which importer are you using on the Blender side, the default LWO one?

I don't think that one knows how to import vertex normals - getting in the proper vertex normals is the best way to avoid shading problems.

Try this instead - in MoI set "Output: Triangles only" (or "Output: Quads & Triangles" should be ok too).

uncheck "Weld vertices along edges".

Under Options > Import/Export > LWO options, set "Vertex normals style = Modo".

 

Then when importing into Blender, instead of using the default LWO importer, instead use the one that Anthony wrote which you can find here:
http://moi3d.com/wiki/Resources#Blender_importer

That one will bring in the vertex normals and should help to make a much higher quality shading. The only problem with it is that it does not bring in any material/style information, just geometry only.


If you want to bring in styles and materials you can try OBJ format instead, but there seems to be some different problems in Blender's OBJ importers, one of which is that the standard one throws away vertex normals instead of bringing them in. I have a modified version in this thread here:
http://moi3d.com/forum/index.php?webtag=MOI&msg=3164.11
which has been changed to keep the vertex normals that are loaded in which seems to help a lot. But I seem to remember Mark Brown running into a variety of additional bugs in the Blender OBJ importers for handling materials in OBJ files as well though.


- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  d^^b (DAVID)
3343.3 In reply to 3343.2 
Sorry Michael. I´m so slowly posting the message that you have answered me before I´ve finished.

Anyway looks that I follow the properly steps. I wonder if the problem is the few points under the Loft command....or it´s only that the surface is bad made.

P.S. I´ve just seen your answer by mail. Thanks for the Rebuild doubt! :-)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.4 In reply to 3343.3 
Hi David, so you have the problem with just one particular surface?

If so could you please post it as an attachment here, or e-mail it to me at moi@moi3d.com ? That would help me to be able to better analyze your problem.

Possibly if your loft is twisted or bunched together, or folded back on top of itself it could make for bad looking areas inside of it.

But normally you should be able to see such bad areas like that in the MoI display as well.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.5 In reply to 3343.4 
Ooops, I see now you have edited your original message and have posted the file there, I'll take a look.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.6 In reply to 3343.1 
Hi David, so just the first impression from your screenshot is that those look like the kind of artifacts that can happen when the shading is not coming from the original vertex normals from the file but rather calculated by just averaging the adjacent polygons.

I'll give it a try over here and see if I can reproduce it though.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.7 In reply to 3343.1 
Hi David, also,

> The surface is built by Loft with Loose and 5#points (First doubt.
> I don´t know if there aren´t points enough)

It should not have anything to do with that - when you see those kind of triangles in the shaded output, that's a problem with the vertex normals not coming over, not likely anything to do with the original surface.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  d^^b (DAVID)
3343.8 In reply to 3343.5 
We are crossing our messages. :-)
Thanks for your attention ;-)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.9 In reply to 3343.8 
Hi David, are you sure you are using the right importer when going into Blender?

Note that Anthony's improved one will show up in Blender listed as:
"MoI with Normals (.lwo)"

It looks like this:




There is also one in the same list called "LightWave (.lwo)" - that's the default one and not Anthony's version, you don't want to use that one because it will not bring in the vertex normals.


Then the other thing is in MoI, make sure you set Options > Import/Export > LWO Options > Vertex normals style = Modo

Anthony's importer expects normals in the Modo style and not the Lightwave style which is what you mentioned you had it set to before.

Does that make any improvement?

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.10 In reply to 3343.8 
Is there any way in Blender to just render the current 3D "user" view with an automatic light source applied, instead of needing to set up the camera to make a full rendering?

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.11 In reply to 3343.9 
Also the front part of your hull has a kind of stretched out area to it, which is making some pretty skinny triangles:



Try using the "Divide larger than" setting to force some additional polygon dicing to reduce some of those longer triangles. For example here is with Angle = 8 and "Divide larger than" = 4 :



- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  d^^b (DAVID)
3343.12 In reply to 3343.10 
Hello Michael:

I must to change this option:Options-->Import/Export--> LWO options: Lightwave to Modo

Then, I have the properly script in Blender. I use "MoI with Normals" as well as you have show.

There are a button for change the way of view. I don´t know if this is that you are looking for.

It´s late now in Spain, but tomorrow I´ll try to use the "Divide larger than" setting, and change the LWO options for improve my surface.

Thanks a lot!

David
Image Attachments:
Size: 169.2 KB, Downloaded: 22 times, Dimensions: 1400x1010px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.13 In reply to 3343.11 
Taking a closer look in a couple of areas, it looks like you may have some issues where the outside trim edges are not very good in some areas, there are a few spots around the outer boundary where things look a little strange.





One issue is that you've got some little segments in there that are of pretty small size in comparsion to the main surface, like this one:



That may be causing some problems with trimming such a large surface using much smaller curves like that.. You may need to ensure that the cutting curves touch each other more precisely before using them to trim with.

how was the outer trim of the hull created, could you possibly post the cutting objects that were used to make the outside outline of the final hull?

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  ycarry
3343.14 In reply to 3343.13 
Hi David
Blender import perfectly the hull as Wavefront .obj
with export as i.e.:
-Triangles only
-Angle 12
-Divide larger than 1 curved
-Avoid smaller than 1
-Aspect ratio limit 1
Considering the type of object (larger piece of a boat) only curves
you can have a count of vertices >8000
and a subsurf modifier 1 level give fine result.

EDITED: 23 Feb 2010 by YCARRY

Image Attachments:
Size: 63.5 KB, Downloaded: 44 times, Dimensions: 1229x455px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  d^^b (DAVID)
3343.15 
Very thank you Michael and ycarry.

Definitively I had two problems. A bad managing of the export options....and I am a dreadful modeler!

The thing is that the hull was any rare parts in the areas that Michael searched yesterday. I uploaded only the main part of the hull, but I had filleted another surface and I damaged the hull.

I show one of the conflictives areas when the mesh is built.(first image)

ycarry: when I export with your settings, I get too much polys, do you? (second image). Anyway your good advice (for MoI and for Blender) have been very useful for me.

Thank you again! ;-)
Image Attachments:
Size: 451.9 KB, Downloaded: 23 times, Dimensions: 1200x879px
Size: 1.3 MB, Downloaded: 29 times, Dimensions: 1200x879px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.16 In reply to 3343.15 
Hi David, so do you need any more help with this, or do you have a solution now?

But it looks like the damaged areas could be due to a bug in trimming or filleting or something like that. It could be related to the small size of that area in relation to the full surface.

It may be something I can fix by automatically tightening a calculation tolerance. If you are able to show me the steps that were done to create those areas, like if you have the model before doing it that you can send to me so I can repeat it over here, then that may help me to track down and solve the problem.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  d^^b (DAVID)
3343.17 In reply to 3343.16 
Hi Michael:

I thought that I could to solve the problem with the hull erasing the surfaces I had filleted with, and drawing another curves for trimming a bit bigger, but now I see that the problem is there.

I send you the 3dm file with the hull and with the curve that I used for trimming it
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.18 In reply to 3343.17 
Hi David,

> I send you the 3dm file with the hull and with the curve
> that I used for trimming it

It looks like the file has the already-trimmed surface in it though.

Do you have a version with the surface _before_ trimming, so I can repeat the actual trim operation over here with that cutting curve, to see what is happening in it?

I can try to untrim and then retrim the one you sent, but there are also various other cuts on other sides in addition to the trim curve that is in the file.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3343.19 In reply to 3343.17 
Hi David, so I untrimmed the outer boundary of your hull, and then retrimmed with the cutting curve you have in the file there. Note that this also removed some trims from the sides and I don't seem to have the cutting curves for those ones in the file you sent.

But when I do the trim over here, those areas seem to behave fine:




What is the exact process that you are doing when you are trimming the hull?

Are you doing something like projecting the curves on to the surface as an extra step before doing the trim? If so, then avoid doing that - instead just use your planar curve directly inside the Trim command as the cutting object, and let the projection mechanism built directly into the Trim command handle the projecting.

It actually makes things a lot more difficult for MoI when you project things on to a curved surface as an extra step before the Trim, because it actually makes the Trim command do a bunch of extra work to re-pull the 3D curves down to the UV space of the surface again.

Anyway, if you let me now what steps you are doing to trim the hull, and possibly if you can send me the surface and cutting curve _before_ doing the Trim so that I can repeat your steps over here, that may let me help you further.

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  flatdog
3343.20 In reply to 3343.2 
Michael,

Forgive my ignorance but where do I put the .py file for the amended .lwo importer for Blender?

Thank you,

Philip
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
Show messages:  1-20  21-24