Chamfer not working

Next
 From:  NightCabbage
3292.1 
Hello

I am having a problem with the Chamfer tool...

I have 2 objects in this file...
The one at the back of the picture, which the edge chamfers correctly.
But the one at the front does not chamfer at all (I've highlighted the edge in the picture).

How can I do this?

Thanks!
Attachments:

Image Attachments:
Size: 107.4 KB, Downloaded: 23 times, Dimensions: 477x357px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  SurlyBird
3292.2 
Hi NightCabbage,

I took the liberty of poking around a bit with your file and within a few minutes I was able to get a chamfer (I went with .25 units). I rebuilt several of the surfaces. I split the offending surface block in half, rebuilt the top and side and closed the bottom (probably not necessary but I wanted it to be a solid when I finished). After a little clean-up, the edge in question chamfered nicely. I'll attach my attempt. Is this going to be a space ship?

EDITED: 3 Feb 2010 by SURLYBIRD

Attachments:

Image Attachments:
Size: 94.7 KB, Downloaded: 42 times, Dimensions: 723x474px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  SurlyBird
3292.3 
I like this better as it matches the other piece more closely.
Attachments:

Image Attachments:
Size: 83.4 KB, Downloaded: 11 times, Dimensions: 819x554px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3292.4 In reply to 3292.1 
Hi NightCabbage, the reason Chamfer did not work along that one edge is that it was not actually a single edge, it was 2 separate edges with a small empty gap between them.

For example if you zoom in to this area here:



You can see that there are 2 edges there:



For Chamfer or Fillet of an edge to work, it needs to be an edge that is a join between 2 surfaces, not one that is unattached to anything.

There are some other areas of that shape that have some significant gaps between the surfaces, like in this nearby area here:



Those pieces need to be built with greater accuracy so that the edges of the surfaces come closer to one another and can be joined together.

How did you create those surfaces initially? You should generally try to build things like that more directly off of the same shared curves so that they are closer to one another and can then be joined together rather than having larger gaps between things.

Does the update that SurlyBird posted above solve your problem though?

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3292.5 In reply to 3292.4 
Hi NightCabbage, it kind of looks like you may be making those surfaces sort of one at a time and drawing curves for each surface individually and just kind of eyeballing the curves to try and make them similar to one another.

That's not going to produce enough accuracy to join things together - instead of making an individual curve for each surface that you want to create, you've got to share more of the curve structure between pieces.

Like for example do not draw in 2 separate curves for this area here:



Instead of having drawn in 2 separate curves there, you want to have just one curve drawn there and then use that same curve in the construction of both surfaces coming off of it, that way the surfaces will be close enough to one another to be joined together and have a common edge.

If you just create a bunch of surfaces that are somewhat visually close to one another but actually come from totally different curves the surfaces generated from those different curves will not necessarily be close enough to each other to be joined.

Edges must be within 0.005 units of each other to be joined together into a single common edge. It's easy for things to be further apart than that if you are just drawing visually similar curves instead of using the same curves directly.


You can also do things like use the edges of an existing surface as the curve inputs to commands like Network or Sweep, that's another way of making sure that the generated surfaces are going to be within tolerance of the existing ones. Using edges in that way can be handy if you don't happen to have the original construction curves around anymore.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3292.6 In reply to 3292.1 
Hi NightCabbage - here's a bit of an illustration on how that area can be repaired by building a surface that touches the others with better accuracy.

To start with, I duplicated this edge at the bottom, by selecting it and then doing Copy and then Paste:



Now select the inaccurate face here and just delete it:



Now to make a better surface there, select these 4 curves - note that 3 of them are edges of the other surfaces:



And then run Construct > Network to build a surface from them. The generated surface will be within a good tolerance of those existing edges, so you can then select those surfaces and use Edit > Join to glue them together and get a proper single joined edge in that spot.


Once you have that set up, you can then select that edge:



And then Chamfer will work on it since it is a good single joined edge instead of it being 2 unattached edges with a gap between them:




That's the kind of sequence that can be used to repair something like this that has some pieces that are unjoinable because they are too far apart.


- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  NightCabbage
3292.7 
:D

Thanks so much for the info!

I'm learning a lot!

I'm not sure how I managed to create extra egdes - oops! I'll have to keep an eye out for that sort of thing...

Also, it's going to be a hover tank - I'll post it, along with some others, after I've done a bit more work on them :P
(they only need to be simple, as they're going to be very small in my game)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3292.8 In reply to 3292.7 
Hi NightCabbage,

> I'm not sure how I managed to create extra egdes - oops!
> I'll have to keep an eye out for that sort of thing...

It's hard to say exactly how that happened without watching the steps you used...

But it kind of looks like you may be drawing in some separate curves for different surfaces rather than building them all off of a single shared curve framework.

There some other kinds of ways that could happen too though, like using a surfacing command that did not make use of some curves, like a one-rail sweep instead of two-rail sweep or network... possibly something like that anyway.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  NightCabbage
3292.9 
Ok, I've come across a problem, and I'm not sure what's causing it...



See the hole / overlap of the surface on the curves?

Why is it doing this?

(it's a network on some curves)

Trimming problem?

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3292.10 In reply to 3292.9 
Hi NightCabbage - actually there is nothing wrong there at all, that's just a display artifact from getting a coarse display mesh in that area.

That can tend to happen in areas that are pretty shallowly curved - not quite enough triangles got added into that spot.

That is something I want to tune up in the future, but for now the solution is to just treat it as a side effect of the display and ignore it.

If you see a more chaotic appearance in areas like that, like with maybe some dark streaks, then that is something to be more worried about.

When you go to export, you will have a chance with the export mesher to get more polygons in those areas if you want by using the "Divide larger than" setting.

The display mesher is more oriented towards doing things very quickly and in some situations it takes some shortcuts which can have a slight visual side effect like you have run into here.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  NightCabbage
3292.11 
Oh, good! I was hoping it was something like that :)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All