Hello I am using MOI to translate Solidworks 2008 and 2010 files into quad geometry for rendering in Modo.

Next
 From:  skateboardkid
3250.1 
This is a very very nice piece of software!
I will be doing around 40 pieces of furniture and rendering for a catalog once i get the translation ratio's figured out, everything I render ends up in environments with other pieces. And so the import scale has to be absolute or scalable in a way that I can control it.

Currently I import IGES files from SW.

Q1.
Does the .lwo exporter size the models based on mesh density or polygon count instead of actual size?

My room seems to be scaled larger at a point .2 than the chair at .2 upon export to .lwo?
I will double check everything, and get back to you.

thanks!

EDITED: 19 Jan 2010 by SKATEBOARDKID

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3250.2 In reply to 3250.1 
Hi skateboardkid, I'm glad that you are finding MoI useful!

> Currently I import IGES files from SW.
>
> Q1.
> Does the .lwo exporter size the models based on mesh density or
> polygon count instead of actual size?

It doesn't change the size of the models based on mesh density or polygon count.

But by default it just translates coordinates directly over to the .lwo file, for unit scale to be preserved you'll probably need to set the option to scale into Meters when writing the lwo file. Some programs like Modo expect to have the data in the .lwo scaled to be in Meters.

In MoI v2 there is an option for this under Options > Import/Export, here:



In MoI v1 that is not in the dialog but I think it is still available by editing moi.ini, let me know if you need more instructions for setting that in MoI v1.

Another way you can do it is to go to Options > General and change the current file's units into Meters before exporting.


Please let me know if that does not solve your problem.


- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  skateboardkid
3250.3 
Will try the option dialog and get back to you - thank you so much for the info!

on another note, as soon as set it to inches i did some measuring with a line and its spot on.
I also noticed that -
The option to divide (larger than) - on curved surfaces really brought out the detail that I originally modeled in the chair. - much more even square polygons than i was experiencing with the measurement system set to none.


ahh I will set it to meters and keep testing I just re-read your post.

EDITED: 19 Jan 2010 by SKATEBOARDKID

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3250.4 In reply to 3250.3 
Hi skateboardkid,

re: Divide larger than - yup that can help to add refinement in areas that have shallow curvature.

That's also how you can produce more finely diced up polygons if you want to do stuff like displacement on them.

Hopefully just setting that checkbox option under Options > Import/Export should do the trick for your scale problem.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  skateboardkid
3250.5 In reply to 3250.4 
Here is my complete work through to get near perfect results from MOI importing IGES and exporting .lwo from SW 2008 to modo 301.

Open assembly in SW
"Save as" IGES .igs
Under Options - Solid Surface features - Output as - "CHANGE TO" - Manifold Solid B-rep Object type 186.

Surface representation/system preference - standard
check box next to
Export 3d curve features
Use High Trim curve accuracy

IGES asembly structure
check
Save all components of an assembly in one file
Flatten assembly heirarchy

select OK

close / minimize SW

Open MOI
Set - options - general - to meters
Select UNIT OPTIONS
Set Default Unit system - to Meters

Select all and rotate 90 around origin - This sets my model flat and centered on the work planes - you may or may not have to do this.

SAVE AS - .LWO

I use the following settings
Angle 12
Divide larger than .25 curved
Avoid smaller than .01 which is around 2" on my mesh
Aspect Ratio Limit 2

select OK

Model should be near perfect geometry in Modo , with each part individually selectable for materials.

I will (probably) post some renders in the next few hours.

EDITED: 20 Jan 2010 by SKATEBOARDKID

Image Attachments:
Size: 209.2 KB, Downloaded: 114 times, Dimensions: 1284x1020px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3250.6 In reply to 3250.5 
Hi skateboardkid, that's great that you have a workable method now!

A few comments:

You probably want to use File > Open in MoI to bring in the IGES file and not File > Import. The reason why is that when you use "Open", it will also set the current unit system to be the units that are stored in the IGES file.

When you use File > Import in MoI, that means to merge the file you pick with the current model instead of replacing it, which also means the the unit system setting is not taken from the file either, but the imported file is instead scaled into the current unit system unless you have disabled the option for that.


If you do that (use "Open" and not "Import") and then also set that checkbox option under Options > Import/Export > LWO options > Scale output units to meters, then you should not need to adjust any unit settings separately.


Also in MoI v2 there is an option you can set in the moi.ini file that will automatically rotate imports from IGES files - the issue with rotation is that SolidWorks puts the Y axis pointing upwards instead of the Z axis pointing upwards like most CAD programs do.

To automatically rotate IGES imports, go to Options > General, and push the "Edit .ini file" button. This will pop up the moi.ini file in notepad.

Find the section that says:

[NURBS Import]
RotateYUpToZUp=n

And switch that to say =y like this:
RotateYUpToZUp=y


Then save out from notepad, and then when you start MoI it should automatically rotate your IGES import without needing to do any extra rotation step.


Those are a couple of ways you can shave off some extra steps in your process, please let me know if they don't work for you.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  skateboardkid
3250.7 In reply to 3250.6 
Thanks for the tips I might have to update my tut at some point to reflect those changes.

I am having an issue with MOI either not being able to open 1 of my designs or it hangs at 50 percent of CPU usage and about 70,000k of memory usage. Weird because every other furniture piece I have imported comes through without a hitch.

Could you take a look at this file?

I can email it directly to you as its a confidential design and I cant post a link or image on a forum - thanks.

I have been trying several different settings to get this chair into MOI it either imports nothing at all or it hangs at 50 percent of CPU indefinitely. Changing my settings to trimmed surface type and nurbs surface I was able to import this model into MOI.
Even when I get this file inot MOI when I save as .LWO it uses like 1.4 gigs of memory while saving.

All other models import and export extremely fast - even on a an old Pentium 4 2.4 with a gig of ram.


This is the only model it happens to so far out of five - I will keep you updated and can send you the file to look at its under a MB.

Actually every IGES that contains the internal framing elements will not import, there are a bunch of areas that are 1/16" thick fabric stretched over the subframe or foam elements and maybe this is why they do not import well, I can open my IGES file back up in SW and its clean geometry just trying to clear this up.
I sent you the file attached to a PM.

EDITED: 21 Jan 2010 by SKATEBOARDKID

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3250.8 In reply to 3250.7 
Hi skateboardkid, I received the file and replied to you in PM - it looks like it may be some kind of bug in reading IGES entity 186. I'll need to ask the guy that makes the IGES translators that I use about it.

You can probably avoid it if you change your export settings in SolidWorks to use individual surfaces (which is somewhat more common for IGES), which would be something like entity type 144 or type 143, rather than entity 186.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3250.9 In reply to 3250.7 
Hi skateboardkid, now that I read your message more carefully I see that you did already try using separate surfaces and that you got that big 1.4 Gig file when doing that.

That is due to a problem that MoI v1 has in dealing with an IGES file that has many solids in it instead of only 1 solid in it. MoI v1 gets confused when it tries to join all those surfaces into solids, it can mistakenly try to join pieces together that came from adjacent touching solids and that can make a big mess.

That is fixed in MoI v2 - in MoI v2 only surfaces that belong to the same "level" in the IGES file are attempted to be joined to one another.

For MoI v1 you are best off exporting only one part at a time instead of exporting multiple parts into one single IGES file.

It is also possible to turn off automatic joining on import, in MoI v2 it is a setting in the options dialog, but in MoI v1 it is in the moi.ini file only.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  skateboardkid
3250.10 In reply to 3250.9 
I am still having some problems with the exported geometry - the are are some surfaces doubled up and most main fillets have flipped normals.


Maybe I can send you a couple more small files and you can send them back to me out of v2?


The geometry looks unbelievably good in the preview window and I would just love to resolve this issue without bugging you too much, I have tried adjusting nearly every setting in MOI and in the IGES export in SW. I am not going to run test until I am out of options tonight and then get back to you in the morning.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
3250.11 In reply to 3250.10 
Hi skateboardkid, yes certainly send me some sample models if you can.

I've actually heard back from the guy who makes the IGES translators that I use and the problem with that one type 186 model that would not come in should be fixed for the next v2 beta. It was actually an error in the IGES structure that SolidWorks created for that one model with a void pocket in it.

> the are are some surfaces doubled up

If you're using v1 this can happen if you have multiple solids within a single file and those solids have overlapping or touching pieces.

To avoid it, there are a few options - the best is to use v2 where that is solved, or you can only export one solid per IGES file instead of putting multiple parts inside of a single IGES file, or you can turn off automatic joining which in v1 is an option inside of the moi.ini file that you have to edit with a text editor like notepad.

> and most main fillets have flipped normals.

That can end up happening if pieces did not join together into a complete solid.

In v2 you can tell if an object is a solid or not by the object type indicator that shows up in the upper right corner of the window that gives some information about the selected objects.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All