HELP! Cant make this a solid (only joined surfs)

Next
 From:  Samuel Zeller
3237.1 
Hello everyone, here's a basic shape made from a loft. And a mirror
Its supposed to be a soap and there will be engraved text so I need to make this a solid.
I cant make one, I only have joined surface :( I dont see where there is a problem :(

Attachments uploaded.
Thanks for your help.
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Brian (BWTR)
3237.2 In reply to 3237.1 
Extrude the shape and give it a 12 fillet.

Brian
Image Attachments:
Size: 150 KB, Downloaded: 100 times, Dimensions: 1024x640px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  eric (ERICCLOUGH)
3237.3 In reply to 3237.1 
Sorry DesuDeus,

I cannot make it work either. It will need someone more skilled than I.

eric
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Samuel Zeller
3237.4 In reply to 3237.3 
Brian nice result but its not what I want. (not exactly the same but close)
Its a very precise work for procter and gamble :)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  PaQ
3237.5 In reply to 3237.4 
Hi DesusDeus,

Add this in your shortcut list :

script:var gd = moi.geometryDatabase; gd.deselectAll(); var breps = gd.getObjects().getBreps(); for ( var i = 0; i < breps.length; ++i ) breps.item(i).getNakedEdges().set

I personnaly map it on the 'N' key (for naked) ... it will highlight naked surface problem ... actually there is something wrong on the top

You can actually fixed it by>Joining your surface
>Select your object
>Hit Planar

If will fill the micro naked open surface, so you end with a solid ...

You probably better to restart the surface from scratch, must be something wrong in your buidling method

EDITED: 3 Feb 2010 by PAQ

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Samuel Zeller
3237.6 In reply to 3237.5 
Thank you so much PaQ you save my life :)

"You probably better to restart the surface from scratch, must be something wrong in your buidling method"

What are your method to this kind of shape?
Im using a Loft selecting in order all the splines and checking "closed"
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Colin
3237.7 In reply to 3237.1 
Hi DesuDeus,

Here's another one & another way for you.

regards Colin

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3237.8 In reply to 3237.1 
Hi DesuDeus, your surface in this case has a kind of 2 "partial poles" in it where some but not all of the surface collapses down to a single point.

That's probably going to cause some various kinds of problems - for just 1 single surface it is ok if the entire surface collapses down to a pole like with a sphere but it is not good to have only some portions collapsed to a pole.

Try leaving just a very small amount of space between each section rather than having them actually collide. Then after the Loft fill in the small remaining area with Construct / Planar. See attached file for an example.

- Michael

EDIT: Same kind of thing as Colin posted above...

EDITED: 12 Jan 2010 by MICHAEL GIBSON

Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3237.9 In reply to 3237.1 
Like for example one problem with the 2 "partial poles" would be that to make that an actual solid directly, that one single surface would need to have an edge that was joined to its own self (to the same surface I mean). The surface joining mechanism is not expecting to see that kind of a self edge join except for the regular "seam" edges on a closed surface.

Also with Loft having points stack right on top of each other will sometimes cause the loft to be a bit unpredictable right in that collapsed area, like you may get some very little bulges and things like that which will be hard to see, particularly if the points are separated by even a tiny amount instead of 100% unified into one location.

By giving just even a small amount of clearance space it is going to avoid these kinds of problems.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Brian (BWTR)
3237.10 In reply to 3237.9 
In trying to persevere with my simplistic approach, just do an extrude up the middle and boolean the two, I am finding these "wings" turning up?

What am I doing wrong with my initial sweep?

Brian
Attachments:

Image Attachments:
Size: 157.1 KB, Downloaded: 59 times, Dimensions: 1024x640px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
3237.11 In reply to 3237.10 
Hi Brian, it looks like a problem in the mitered corner extension for sweeps.

From the Dec-19 v2 beta release notes:
quote:
The only area that is still actively in progress and known to still be buggy in this release is the new corner mitering for 1-rail sweeps especially on curved rail segments


You're running into that because your path curve's end tangents are not smooth to one another - there is a shallow kink in this area of the path:



Before you mirror a piece, try to make sure the first 2 and last 2 control points are aligned so that the curve is perpendicular to the mirror axis rather than at a slight angle to it.

One easy way to do that is to turn on control points, and use the Transform > Align command to make sure they are lined up in a straight line and not slanted slightly like you have here.

If you make the path curve all smooth without any sharp areas in it, then it will not try to miter the corners and should avoid the unwanted extension that you are seeing currently.

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Brian (BWTR)
3237.12 In reply to 3237.11 
Thanks Michael

Achieved my simplistic aim!

Brian
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Samuel Zeller
3237.13 In reply to 3237.12 
Thanks Michael.
It worked great :)
I didn't know that overlapping points can cause this sort of problems.

Topic resolved :D
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All