missed faces

Next
 From:  andras
2968.1 
Hello guys!

Sometimes when I work with [mm] or [cm] I miss faceswhen I use extrude command. but when I work bigger object the probleme is not visible. Can I modify somewhere treshold senstive value?
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2968.2 In reply to 2968.1 
Hi andras - MoI's extrude currently uses a tolerance set at 0.001 units and if you have curves that have some segments in them that have a length smaller than that, it can cause that kind of missing face problem when extruding them.

That may possibly be what you were running into.

But it is hard to know for sure without seeing an example, can you please post a 3DM file (or e-mail it to me at moi@moi3d.com) so I can try to repeat the missing face extrusion problem over here? If I can repeat it over here I can more definitely trace down the problem rather than just trying to guess.

I do have a fix for the small segment issue in the next v2 beta though, the tolerance for the extrusion will be automatically adjusted to be tighter if there are small segments being extruded.


> Can I modify somewhere treshold senstive value?

No, the tolerance value in MoI cannot be adjusted - it tends to cause a lot of weird problems to make that value adjustable. Things like receiving a file from someone else with an altered tolerance in it, then trying to build new objects and having them come out strange because you are not really aware the tolerance is not what you were expecting, stuff like that.

Also I am generally working towards making the tolerance be adaptable to be a fraction of the overall size of the objects involved in the operation rather than only one fixed value.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  andras
2968.3 In reply to 2968.2 
Hello Michael!

I modeled an fireplace and when I extruded I have got this unexpected result:
Anyway I have had already some similar results at another projects (when I modeled the car just n that case I use Trim command )
but this is not a big problem however well I dont use 3d print machines but somebody perhaps and...
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2968.4 In reply to 2968.3 
Hi andras, thanks for posting the example!

But I can't seem to find the curve that you extruded in that example, could you please post the curve for me so I can do the extrusion over here to repeat the problem instead of only seeing the already completed result?

That would help a lot for trying to track down the problem.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  andras
2968.5 In reply to 2968.4 
Hello!

The probleme is with only small one. anyway no matter.
I deleted the original one but I managed to reproduct thats why I think that tolerance value
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2968.6 In reply to 2968.5 
Hi andras, thanks for the example file, that helps a lot when I can repeat the problem over here.

It is a problem related to the tolerance value - segments that approached too close to that tolerance value could generate a bad extrusion with the small piece kind of collapsed down on itself.

It's fixed up for the next v2 beta, so this example and others like it should be working ok after the next beta release.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  andras
2968.7 In reply to 2968.6 
thank you
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  andras
2968.8 In reply to 2968.6 
Hello Michael. Currently I have similar probleme with Loft command... the command is not working maybe the tolerance again?
you can see two simple circle in the scene.

EDITED: 18 Oct 2009 by ANDRAS

Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2968.9 In reply to 2968.8 
Hi andras, actualy this problem is somewhat different, it's a failure of the automatic un-twisting mechanism.

There is a process that MoI does in some operations like Loft to line up the "seam point" of a closed curve when combining them together into a surface to try and avoid making a twisted result.

In this case it is not working properly, and the surface that it is trying to generate is all twisted and messed up.

You can fix it though by adjusting the seam point by dragging on the little grips that show up in the viewport at the "Loft options" prompt before you exit the Loft command. When you get them aligned well, the surface will then pop in like this:



I'll put this on my list to look at in the future, it would be good if the automatic untwisting optimizer would handle this better, but it most likely has something to do with the very long and skinny shape. And actually a kind of tolerance is likely to be involved as well - there is a part of the untwister that decides if the "natural" seam orientation is close enough to the optimized one, it will use the natural one instead. It looks like that is getting triggered here and the natural seam of each circle in this case are rotated by 180 degrees from one another.

So another workaround to fix it is to rotate one of the circles by 180 degrees which you can do using the rotation grip on the edit frame.

- Michael
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  andras
2968.10 In reply to 2968.9 
thanks it is interesting. but dont work on Sunday :) .thanks again
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2968.11 In reply to 2968.8 
Hi andras, by the way the Loft problem that you reported here between those 2 little circles should now be fixed in the new beta.

Thanks for reporting it and for sending the file to test with.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  andras
2968.12 In reply to 2968.11 
not at all. yes I know I have read your review about new beta. thanks
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  andras
2968.13 In reply to 2968.11 
Hello michael I found a similar issue in the new beta (October) version.
I used planar command . If I scale the object the problem is not existing.
Attachments:

Image Attachments:
Size: 25.4 KB, Downloaded: 19 times, Dimensions: 1074x706px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Ralf-S
2968.14 
I have no problem, please take a look. :)
Attachments:

Image Attachments:
Size: 5.1 KB, Downloaded: 13 times, Dimensions: 519x187px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  andras
2968.15 In reply to 2968.14 
it is strange. I am using the latest beta. But your file is 25 kb mine is 24 kb.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Ralf-S
2968.16 
...hmm, the problem is not the file size. (I also use the V2 Beta Oct-19-2009, Vista 64 bit)

After creating your geometry/figur with curves, you have to "Join" the curves and then you can use "Planar". ;-)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
2968.17 In reply to 2968.13 
Hi andras,

> Hello michael I found a similar issue in the new beta
> (October) version.
> I used planar command . If I scale the object the problem
> is not existing.

Yeah, this is the same issue as before - the line that does not behave well there is very tiny in size, only 0.001 units long.

I just do not currently recommend making objects that have any individual features at such a small size (especially approaching close to 0.001 units), you will likely continue to run into this problem many more times with trying to create objects at that small scale right now.

I have adjusted the Planar command for the next beta so that it will work properly for this now though.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All