ZBrush problem re-visited

Next
 From:  Joe (JPITZ31)
2833.1 
Hello All,

I hate to bring up this topic again, as it is more than likely related to the way the polygons are unevenly spaced, but here goes.

I extruded my Chinese character and exported to .obj file using n-gons, weld on, shaded and edges, angle = 12.

I am using ZBrush 3.1 on a vista machine.

When I attempt to import the Chinese Love.obj (n-gons) into
ZBrush, ZBrush dies on the import.

When I Export with Quads & Triangles and the rest of the settings the same, the character imports, I turn off the SMT Smooth button, even though, 3.1 is suppose to fix this.

Then upon trying to smooth the edges, the character becomes very jagged. My question is what is causing ZBrush to hang on the n-gon export.

Would the n-gon export address the uneven polygons?

Also any suggested would be appreciated.

Enclosed are some files to test.

Thanks

Joe

Image Attachments:
Size: 109.9 KB, Downloaded: 73 times, Dimensions: 1280x1024px
Size: 91 KB, Downloaded: 71 times, Dimensions: 1280x1024px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Joe (JPITZ31)
2833.2 
Here is the .3dm file if you need it.

Thanks

Joe
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2833.3 In reply to 2833.1 
Hi Joe, yeah ZBrush simply does not handle n-gons properly so you need to avoid them when exporting to there.

The last time I tried it, it did not crash with n-gons but instead made improper objects since it created triangles from all n-gons just by connecting the n-gon outline to a single centroid point, which only works for convex n-gons and not ones with complex boundaries.

So anyway whether it crashes or makes improper triangles, n-gons are not handled by ZBrush.

You also do need to turn off the smooth subdivide option, since that is only meant to subdivide a sub-d cage and the models that you export from MoI are not set up as sub-d cages.

Because of that you need to subdivide your model into smaller polygons at export time from MoI rather than relying totally on subdividing in ZBrush. Otherwise if you have too large sized polygons in your initial export, the subdivide in ZBrush will only follow those flat polygon shapes and give you a kind of faceted result. By dividing it up more finely in the initial MoI export, it will give you smaller polygons that follow the curvature of your original model better.

There is a previous discussion thread on this here:
http://moi3d.com/forum/index.php?webtag=MOI&msg=804.26

I'll take a look at your model and see if I can give you some specific advice for it.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Joe (JPITZ31)
2833.4 In reply to 2833.3 
Thanks Michael, I will take the polygons to the smallest and try again.

Joe
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2833.5 In reply to 2833.1 
Hi Joe, here are some mesh export settings to use for your particular model, that should get things working well with ZBrush.

To start with, when you export to OBJ you will want to expand the Meshing options dialog to get at the additional controls. To do that, click on the little arrow in the lower left corner of the dialog here:



Then there are 3 settings that you will need to adjust:

1 - Set output to Quads & Triangles

2 - Set "Divide larger than" to have a value of 0.5. This subdivides any polygons larger than 0.5 units in size, so it will cause polygons to be more finely diced up.

3 - Set the control for what "Divide larger than" applies to, to "All". This is the control that is directly to the right of the Divide larger than numeric entry.

Here is a screenshot showing you where these 3 controls are located:




With those settings in place, you can see in the screenshot there how your model will be diced up into small sized bits when you export from MoI - that is the kind of output that ZBrush is going to like to work with.

Then inside of ZBrush if you need to, you can turn the smooth modifier off and subdivide once or twice if you need to get some even smaller dicing. That will be a lot better behaved in ZBrush with this data now, it is not really set up to work with polygons that may cross over a large area of the model like you were previously getting in your previous mesh export.

Let me know if you still have any problems, hope this helps!

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2833.6 In reply to 2833.4 
Hi Joe,

> Thanks Michael, I will take the polygons to the smallest and try again.

Also note that you'll need to use more than just the simple slider control, you'll need to use the "Divide larger than" setting that I mention above.

That's because the slider works by putting more polygons only in curved areas, that regular slider action basically leaves totally flat areas alone because for rendering purposes you don't normally want to have planes diced up into a lot of polygons, to get smoother looking renderings you only want more polygons in curved areas.

For the specific purpose of ZBrush use you will need to use some of other settings as shown above to break even the planar parts into smaller bits.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Joe (JPITZ31)
2833.7 
Thanks Michael,

The polygons look great now. I will try these settings.

Joe
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All