Export as LWO to Modo...scale issue???

Next
 From:  slayer
2686.1 
I have some parts brought into Moi from SolidWorks as .STEP files. The import is great with no issues and the scale matches that of SolidWorks.

I export out as .LWO and open in Modo. The translation is great, but the scale is way off. I have checked any settings in moi and there does not seem to be anything to do. The model should be about 900 inches long, but it comes into modo at around 3100 feet!

Is this a modo scaling issue or something within moi? I have fudged with some settings in modo, but nothing works.

Thanks
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2686.2 In reply to 2686.1 
Hi slayer, which version of MoI are you using, v1 or the v2 beta?

In the current v2 beta there is an option under Options dialog > Import/Export > LWO options for "Scale output units to meters".

Try checking that option and then I think that will solve your problem - it seems that the way that Modo works for units is that it is expecting the data in the .lwo file to always be stored in meters and if it is some other unit system it needs to be scaled. By checking that option that scaling will happen and then you should see the proper result.

If you are using MoI v1, there is that same option available but you have to edit the moi.ini file to set it. To do that, close down MoI and open up the moi.ini file in a text editor like notepad. The moi.ini file is located here:
C:\Documents and Settings\Michael\Application Data\Moi\moi.ini
That's on Windows XP, it is slightly different on Vista, let me know if that is what you have.

Once you open up moi.ini, look for the [LWO] section, and there is an option there:
[LWO]
ScaleToMeters=n

Switch it to be =y and then you should probably be set up.

Please let me know if that does not work for you or if you have any difficulty changing the moi.ini file if you are using MoI v1.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  slayer
2686.3 In reply to 2686.2 
Thanks for the reply.

I am using V2. I have checked this option.

when I bring it into modo and I make a 900 meter box as reference, yes imported model fits within it exactly.

However my model in SolidWorks and Moi measures 900 INCHES.

With this option checked and unchecked, the model comes into modo at the same size. The only way to fix this is to scale it down to 2.54% of its original size.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2686.4 In reply to 2686.3 
Hi slayer,

> With this option checked and unchecked, the model comes
> into modo at the same size.

If there was no difference at all with the exported mesh when checking or unchecking that option, that likely means that your units in MoI were not actually set to inches, but were either set to "No unit system" or to "Meters"...

Could you please double-check that to see if that is the case? In MoI the setting for the current units is under Options / General / Unit system.

If that's not the problem, then could you please post a sample .3dm file saved from MoI which is not going through properly when saving to .lwo so I can take a look at it over here?

I just did a quick test over here and I couldn't reproduce a problem - if I make a 900x900x900 box in MoI and make sure to set the current MoI units to Inches (this part is important!), then over here when I export that box to .lwo it seems to be working as expected - the box in the LWO file is scaled to have a size of 22.86, which is 900 inches converted to meters.

There is no way to set a "unit marker" in an LWO file to say what kind of units the values in the file are supposed to be, so as far as I know to preserve units Modo expects to have the coordinates in the LWO file to be stored in meters only.

If you set that "Scale output units to meters" option in MoI it should do that for you, but you need to make sure that your units in MoI are also set as well.

Please let me know if you still can't get this to work, and if so a sample file would also help out a lot too.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  slayer
2686.5 In reply to 2686.4 
Hi Michael-

You are correct. My units in Moi were set to "no unit system". I set this to inches and all works great now.

Sorry for the trouble and thanks for your help.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2686.6 In reply to 2686.5 
Hi slayer no problem, I'm glad that it is working for you now!

One thing that may have got things set off wrong is if you happened to use File/Import to bring the STEP file into MoI rather than File/Open.

Import is meant to keep the current model and merge the file you pick into it. So because of this, it does not change whatever units were set in the current model.

But if you use File/Open, the units that were set in the STEP file will become the current units inside of MoI.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  jouli
2686.7 
your post is so much interesting and informative.I like its so much and i says thanks on this nice sharing,

EDITED: 3 Jan 2011 by JOULI

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All