blend ?

Next
 From:  yannada
2514.1 
Note the creases when G2 applied... any logical explanation for that? I also get similar artifacts with 2 rail sweep but the refit option solves the problem.



EDITED: 17 Apr 2009 by YANNADA

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  PaQ
2514.2 In reply to 2514.1 
Hi Yannada,

Looks like meshing preview artefact ... if you lower the mesh angle in the view options (around 3 for example), or if you do a mesh export, you'll see this problem dissapears.

EDITED: 24 Mar 2009 by PAQ

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  yannada
2514.3 In reply to 2514.2 
Thanks PaQ, it does the trick. Now I have to see what mesh angle does...
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2514.4 In reply to 2514.1 
Hi Yannada, that is just a display artifact.

In order to display your surface, MoI breaks it into triangles since your video card only knows how to render triangles and not actual NURBS surfaces.

You're able to see kind of the outline of those triangles in this particular case, that's not a particularly unusual thing in areas that have a lot of changing in their curvature. MoI has some stuff in it where it tries to subdivide triangles in those areas to reduce those artifact, but in this case it just did not happen to get divided down small enough, so you can see the triangles.

Like PaQ mentions, if you go to Options / View, you can set the "Mesh angle" parameter to a smaller value, such as 5 degrees which will cause the display mesh to get a larger number of polygons in it and reduce that display artifact.

However, I actually do not recommend that you leave it set there, since a mesh angle of 5 will produce a much much heavier mesh on everything and if you have a large model with many surfaces in it, the display meshes will start to take up a considerable amount of memory, and also it will take longer for the meshes to be calculated.

So basically that is just something to get used to and ignore. If you do want to check it out, then I would recommend to only lower the mesh angle temporarily and make sure to restore it back to the default so that you can handle larger models better.

The default angle is actually pretty small and creates pretty dense meshes already.


- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  yannada
2514.5 In reply to 2514.4 
Learning everyday,thank you sir.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All