Mesh export glitch All  1  2-6

Previous
Next
 From:  PaQ
2379.2 In reply to 2379.1 
Yes I notice that also, I suppose the meshing should have some option to force to keep the symmetry.
Now, if you cut your model in two, delete the left or right part, mirror it and rejoin everything, the exported mesh will be perfectly symmetric.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
2379.3 In reply to 2379.1 
Hi Giovanni, can you please post the .3dm model file as well as your screenshots?

It is very difficult for me to debug a screenshot, but a .3dm model file does give me something I can test and debug with.

What you are seeing there though is an area of extra subdivisions to make the divided mesh meet the angle tolerance. It is possible that there are very small differences in the fillet surface from one side to the other which could cause that kind of a thing.

Like PaQ mentions, probably the best way to absolutely ensure symmetry is to model half and then mirror, that ensures 100% complete identical surface forms (and also edge topology) between 2 halves.

It's not really very feasible to do only a completely uniform mesh generation in all circumstances, because in many situations it would cause an immensely dense mesh to be created.

Here is an exaggerated example to illustrate, notice how this surface is flat in many areas and only has curvature in a localized area:



If that was meshed with only a completely uniform and regular mesh with no subdivided areas, it would require putting a very heavy and dense mesh even in the flat areas that didn't need it, just to try and adapt to the curvature of that localized area.

So the mesher does not try to do that for every single type of surface. It does try to do it for regularly shaped surfaces like a sphere or a cylinder, but on more general surfaces (which your fillet there falls under) it would in general blow up polygon count by a very large amount.

So in situations like this the mesher does an "adaptive subdivision" which subdivides the mesh only in areas of higher curvature, like this:



That greatly helps to keep the polygon count lower.


Your fillet there is also a pretty high radius in relation to the outer cylinder piece, this probably makes it more likely to have some slight deviations in form since it is spanning an area of higher curvature changes, you will probably tend to see less of this on fillets that are somewhat smaller in size in relation to their surrounding outer forms.

Anyway, if you can post your .3dm file I can take a look at it, but it's probably related to the adaptive subdivision mechanism I described above, which is not really a bug it is a way to try and keep polygon counts lower.

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  carrozza (GIOVANNI)
2379.4 
Hi Michael, your explanation does make sense to me.
Let's just say that from my not-expert point of view it's weird that the "meshing engine" doesn't produce the same polygons on the left and right side of a perfectly symmetrical model.
Not a big deal, as it was said is possible to try avoiding this issue keeping curves less extreme and also correcting glitches in a modeling software.
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Frenchy Pilou (PILOU)
2379.5 
you will have better symmetry if you decrease the number of ngons ;)

Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
2379.6 In reply to 2379.4 
Hi Giovanni,

> doesn't produce the same polygons on the left and right
> side of a perfectly symmetrical model.

If it was actually 100% absolutely "perfectly" symmetrical with not even the slightest tiny difference, then it should behave like you were expecting.

But one of the general problems with computer processing in general is that it tends to be difficult to get "perfect" results, it is not uncommon for results to have very minor deviations, like in the area of 0.000001 units in size for example, particularly with operations such as fillet surface building which has to go through a rather long series of fancy calculations involving calculating offsets and intersections between surfaces...

In this case, those tiny differences happen to be just enough to produce an extra level of subdivision in some of those areas.

If you select that fillet surface and use Edit/Separate to break it out into a single surface, you can then use Edit/Show pts to turn on control points and if you look closely you can see that the control point arrangement of the fillet surface is not 100% perfectly symmetrical.

It is within a pretty tight tolerance value, but not "perfect", if that helps to explain things... That is basically the cause of this problem that you are reporting here.


I do have a couple of ideas that may help to improve this and remove the differences caused by these small deviations, I'll see if it is possible to tune up this area.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
 
Show messages: All  1  2-6