Problem with V2.aug.04
All  1-2  3-9

Previous
Next
 From:  Michael Gibson
1908.3 In reply to 1908.1 
Hi Nick, that's definitely strange, I have not heard anyone else report this problem so far.

Does snapping to curve objects like a line or circle work ok?

What about if you go to the view toolbox on the side pane and switch the checkbox for "Display hidden lines", does that make a difference? If it does then it probably means something is not behaving right on your particular video card for the hidden point determination for object snaps.

V1 did not try to determine if an object snap point was hidden, that may be why it behaves differently.

But also if you have "Display hidden lines" turned on, then v2 will not try to determine if points were hidden so if you let me know if that makes a difference that would probably help me.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Nick (BODINI)
1908.4 In reply to 1908.3 
Aha! That was it, I unticked 'display hidden lines' a few days ago and thats when it happened (although i didnt realize that until you said so).

This happens on both on solids and curves (hadnt realized that either).

One notable thing is that it DOES give a snap point on the FIRST and sometimes second point you create a solid or curve with. I mean, if you drag out a 'corner to corner' rectangle, the only snaps it will give you are the FIRST point you snapped, and the second point, both as 'End'. If you draw an elipse by 'center' the only thing it will snap to is the FIRST quadrant... thats it (except for 'On', which it always gives). If you draw a box with 'corner to corner', you can snap to the start point, the end point, but not the height.

Hope that all helps. Let me know if you need more feedback.

-Nick
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Nick (BODINI)
1908.5 In reply to 1908.3 
You mentioned video card. FYI: It is a NVIDIA GeForce 7300 LE. Thats OEM for this Dell E521, thats about 1 year old. PC is running Win XP sp2.

-Nick
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1908.6 In reply to 1908.5 
Hi Nick - that definitely narrows it down!

It basically means that MoI is not getting the expected information back from the video card.

Could you please try a couple of things?

First - can you please update to the latest drivers for your card here:
http://www.nvidia.com/object/winxp_175.19_whql.html

It may be some glitch in your particular video driver version - over here I have a machine with a GeForce 7350 LE which does not have the problem but I have a recent driver installed.


Another thing - can you please go to your video card control panel thing and look at the anti-aliasing settings and see if you have anti-aliasing turned on in the driver? If you do, can you please switch that to the "application controlled" setting and see if that also fixes the problem?

Thanks,
- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Nick (BODINI)
1908.7 In reply to 1908.6 
Aha again!

I tried the most undoable thing, which was the anti-aliasing option. See the attached screen shot.

When I had the problem, the setting was set to "Use my preference emphasizing:" and the slider was all the way over to 'Quality'.

Then I ticked "Let the 3d application decide", restarted MoI and the problem was gone.

I did this a few times and yes, it is definately a factor with the issue at hand.

I know that I set it to 'Quality' myself a few months or more ago. I cant remember what app it was changed for though... I dont care anyway.

I will update the driver when you reply back, but I'll leave it on there for right now in case you have any other questions. KWIM? :-)

And here i always ignore video card type threads on any forum because those are for fools with outdated systems. D'ohhhhh! :-P

-Nick
Image Attachments:
Size: 307.7 KB, Downloaded: 60 times, Dimensions: 860x729px
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1908.8 In reply to 1908.7 
Hi Nick, that's great news!

Basically, what happens is there are a few times that Nvidia have had a bug in their drivers where they don't listen to MoI's request to disable anti-aliasing at certain times.

For the normal display anti-aliasing is not a problem, but MoI also uses the video card for some selection and visibility related calculations, and anti-aliasing in those particular calculations throws a monkey wrench in there.

You may find that if you update your video driver that you can then have the anti-aliasing setting and also MoI working properly at the same time. But it is not really necessary to do that since you have a solution.

Also even with your current driver version you can leave anti-aliasing turned on for everything, and then go to the "Manage 3D settings" entry on that NVidia control panel and there you can adjust the driver settings for individual programs and turn it off only for MoI there.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Nick (BODINI)
1908.9 In reply to 1908.8 
Thanks for the help!
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
 
Show messages: All  1-2  3-9