Meshing - 'Avoid smaller than' adds polys ?
All  1-4  5-6

Previous
Next
 From:  PaQ
1653.5 
Sure, it's a really low priority bug (if it's a bug) anyway ;)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
1653.6 In reply to 1653.5 
Hi PaQ - it is a bug.

The way "Avoid smaller than" normally works is if an edge is smaller than that distance, it switches to an angle of 35 degrees. The idea is to switch to a rough angle for small features below a certain size, so that those little features don't get a ton of teeny-tiny polygons when you may otherwise have a fairly tight and dense mesh in the regular-sized features of your object.

The bug is that edge refinement was still switching to 35 degrees even if the regular angle was coarser than that (surface refinement was handling this ok). So it actually ended up switching to a tighter angle (just on edges) instead when it kicked in.

I've fixed this for v2 - the fix itself doesn't really do you much good because it just makes sure that "Avoid smaller than" has no effect at all when the regular angle is above 35. So just don't set "Avoid smaller than" when you have an angle > 35 and that will do the same thing.

Thanks for reporting the strange behavior!

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
 
Show messages: All  1-4  5-6