Meshing - 'Avoid smaller than' adds polys ?

Next
 From:  PaQ
1653.1 
Hello here,

It's maybe a misunderstanding from my side, but I don't get how the 'Avoid smaller than' can actually add polys in extreme condition.

I'm actually using the meshing tool too create some really low cage from my modeling, I need to create some simple collision for some particle simulation.
So I did some export test with different settings, testing the 'Angle' vs 'Avoid smaller than' parameter.

So far the best setting for my object is 95° for the angle, to remove every fillet from my hires model.

Here's a sample:



And the result:


However if I put 30 in the 'Avoid smaller than' (the cube is 100*100*100 units), it actually adds polys ... does it make sence ?

EDITED: 3 Feb 2010 by PAQ

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1653.2 In reply to 1653.1 
Hi PaQ,

Did you possibly re-install MoI at some point not too long ago?

There is a bug in the way "Avoid smaller than" is handled in MoI v1, remember we discussed this before here:
http://moi3d.com/forum/index.php?webtag=MOI&msg=1536.1
http://moi3d.com/forum/index.php?webtag=MOI&msg=1536.23

I sent you a patch that fixed that up, are you possibly running a new installation without the patch in place?

If that's not the case, can you please post the model file so I can test with the same exact data over here?

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  PaQ
1653.3 
Hi Michael,

I'm using the moi_lib.dll you give me few weeks ago indeed.
Here's the testing box ...

EDITED: 4 Dec 2015 by PAQ

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1653.4 In reply to 1653.3 
Hi PaQ, I've got to head out for a while, I will take a close look when I get back later, maybe there is still a bug in the handling of "Avoid smaller than".
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  PaQ
1653.5 
Sure, it's a really low priority bug (if it's a bug) anyway ;)
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  Michael Gibson
1653.6 In reply to 1653.5 
Hi PaQ - it is a bug.

The way "Avoid smaller than" normally works is if an edge is smaller than that distance, it switches to an angle of 35 degrees. The idea is to switch to a rough angle for small features below a certain size, so that those little features don't get a ton of teeny-tiny polygons when you may otherwise have a fairly tight and dense mesh in the regular-sized features of your object.

The bug is that edge refinement was still switching to 35 degrees even if the regular angle was coarser than that (surface refinement was handling this ok). So it actually ended up switching to a tighter angle (just on edges) instead when it kicked in.

I've fixed this for v2 - the fix itself doesn't really do you much good because it just makes sure that "Avoid smaller than" has no effect at all when the regular angle is above 35. So just don't set "Avoid smaller than" when you have an angle > 35 and that will do the same thing.

Thanks for reporting the strange behavior!

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All