wavefront-export problems  1-20  21-22

Next
 From:  vinced
1620.1 
Hi Michael,

when i export a model (please see attachements) in wavefront-format, somehow the polygons of one part are not welded.
What is going wrong?

Greetings
Dirk






Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1620.2 In reply to 1620.1 
Hi Dirk - are your surfaces joined together so they share a common edge?

For the resulting meshes to be welded, surfaces need to share a joined edge, so that may be the problem. If the surfaces are totally separate objects that are just next to each other, then that can lead to a lack of vertex alignment between them when they are meshed.

If that's not the problem, could you please post a .3dm file (or e-mail to me at moi@moi3d.com) so I can take a closer look at the actual model data?

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  vinced
1620.3 In reply to 1620.2 
Hi Michael,

the surfaces are actually one object.
I would send you the file immediatly, but if you remember, i have problems sending you the file because of maildelivery errors. I`ve tried your temporary adress at hotmail you gave me last time, but this failed too.
I`ll try to upload it as an attachement here. Don`t know, if that works.

Thanks
Dirk
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1620.4 In reply to 1620.3 
Hi Dirk, that attachment worked, thanks.

Even though that capsule shape is joined into one object, somehow not all of its edges got fused together.



Those 3 edges that I show in green above did get connected together - that happened to connect enough parts together so that it will select all together as one object.

However, the edges I traced in red above somehow did not get connected together.

To fix the problem, select that capsule shape, then use Edit/Separate to break it apart, then follow that immediately by Edit/Join to re-join the pieces together. That will then get all the edges joined and then the cracks should be gone from the mesh.

It seems like there must have been a bug in some earlier operation on the capsule part where it didn't glue some of those edges together. Do you happen to have an earlier version of that particular piece, or do you remember what operation you used to make it, there may be a bug in that which should be fixed up.

- Michael
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  vinced
1620.5 In reply to 1620.4 
Hi Michael,

this is the way i`ve done it:





After that i`ve used boolean union.

Greetings
Dirk
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1620.6 In reply to 1620.5 
Hi Dirk, thanks - I can repeat that problem over here now.

I'll see if I can do something to fix that up in Boolean Union.

But when you have individual surfaces touching edge-to-edge like this, I would recommend using Join instead of Boolean Union. The booleans are more intended to be used when pieces cut into each other, they do a lot of extra work doing things like determining intersections between surfaces and stuff like that.

Join on the other hand is tuned up for this particular kind of case where surfaces are already touching and nothing needs to be sliced up.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  vinced
1620.7 In reply to 1620.6 
Hi Michael,

i`ve discovered another thing. Don`t know if it is a cinema 4d related thing or a moi related thing.
I`ve done a cube and then filleted the four edges at the bottom, exported it as obj.

In cinema there are, where the fillet is, some points which lead to bad uv-polys. These points are connected to the mesh,
but they don`t seem to be necessary.If i delete these points per hand, everything is fine (Also if i use quads&triangles everything is fine).



It`s not a great issue, but is there anything you could do about it or do i have to ask Maxon for a better obj import?

Greetings
Dirk

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1620.8 In reply to 1620.7 
Hi Dirk - can you please post a .3dm file and also the .obj file so I can take a look and make sure I am using the exact same data as you?

From the screenshot, it looks like those points are part of the refinement of the edge. They're probably added there to break down the edge into more pieces so that it fulfills the angle tolerance. If you want fewer of these points you could probably reduce them by lowering the angle tolerance (move the slider to the left).

One thing about the UV space - the way that MoI currently exports UV coordinates, each different surface has UVs that span the entire 0->1 UV space. So if you're looking at UVs, it is normal right now that you will see multiple polygons stacked on top of each other. Is that possibly what you are seeing there?

If not, one thing you may try is turning off "Weld vertices along edges" when you export from MoI - that will tend to produce a more simple structured OBJ file, if there is some problem in OBJ import then that may work around it.

But it is not very clear to me exactly what you have there - I will need to get the files to examine them here to understand.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  vinced
1620.9 In reply to 1620.8 
Hi Michael,

these points don`t seem to belong to the structure of the object, though they are connected to it. It seems that these are polygons added to the edge of the fillet. The uv-polys i`ve shown above weren`t the original uv-polys of MOI. I`ve created them with cinema 4d/Bodypaint and only here i`ve noticed that there was something wrong. When i delete these points, the corresponding polys are deleted too and everything is fine.

Greetings Dirk



  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  vinced
1620.10 In reply to 1620.9 
Here`s another shot from the other side.

It seems Moi or c4d uses a whole triangle for the edge of the fillet.


Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1620.11 In reply to 1620.9 
Hi Dirk, I suspect what you are seeing there is probably a side effect of the way that C4D decided to triangulate that n-gon.

Let me illustrate - say you have this 5 point n-gon:



Now say to produce a triangulation of this n-gon, what if the triangulator starts by placing this triangle:



Then next it places this triangle:



It certainly looks like the triangles it picked were nicely shaped, but it is actually pretty bad because now it only has one possible point left to form the last triangle, and it will be a degenerate one along the side there:



It is not uncommon for triangulation mechanisms to have this problem in them when processing n-gons shaped like that. Some algorithms tend to get led astray because those initial triangles seem nicely shaped, so it starts peeling away those but then ends up with a bad one at the end.

MoI's triangulator goes through some pains to not produce this kind of thing, so that's why you don't see the problem when you export using the Quads & Triangles option in MoI.

I have not reviewed your files yet to verify, but it is pretty likely that is your problem and the black shading is some side effect of the triangle being degenerate when it was created by C4D.

Tomorrow I'll double check your file to verify if this is the case or not. If it is, then I'm not really sure what I can do about it - it would really depend on C4D improving their triangulation mechanism to not create degenerate triangles in situations like this. I guess I could try to avoid creating this kind of shape, but that would probably mean slicing out points that are needed to make the polygon outline appear curved within the angle tolerance...

- Michael

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  vinced
1620.12 In reply to 1620.10 
Hi Michael,

sorry for posting here bit by bit, but i have to correct myself. The last to shots from the lefthand side and from the righthandside are both n-gons.
From one side the ngons are working correct. From the other side not.
Sorry, i`m really no expert here.
The other ways you`ve mentioned above don`t work for me. best thing is just to delete these points.
But if it is some Maxon-related problem i would like to tell them.

Greetings
Dirk
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1620.13 In reply to 1620.10 
Hi Dirk,

> It seems Moi or c4d uses a whole triangle for the edge of the fillet.

MoI is making an n-gon there, there are no triangles involved at MoI's export time (unless you set that option of course) - it just happens to be an n-gon that has several points that are near to being colinear with one another as they follow some curvature.

C4D will take that n-gon and then break it into triangles for display and rendering purposes, and it's that triangulation process that is probably not going quite as well as you would want.

The way that would be good to triangulate it would be like this:



That gives triangles that kind of more gradually spread across the n-gon, instead of the previous case that I showed where you get 2 big triangles and one degenerate one. But unfortunately it looks like you are getting that bad case in C4D's n-gon triangulation.

- Michael
Attachments:

  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  vinced
1620.14 In reply to 1620.12 
Hi Michael,

your were to fast with your reply ;)

If there is no workaround, i can live with that.
I would like to tell maxon about this problem, but i`m not sure if i can explain this issue well enough to them to make them understand.
Well, i will try it and direct them to this thread here.

Thanks for your effort Michael

Dirk
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1620.15 In reply to 1620.14 
Hi Dirk, I took a look at your OBJ file, and it does look to be the problem that I was describing - the triangulation that C4D created is not so good and is following the example I showed above where it pulled out large triangles during the initial stages of the triangulation process and left a degenerate one along the side there.

Actually on the one side where it is showing black, I think that triangle actually got created in the wrong orientation, facing backwards - that's why it is black.


One workaround is to export from MoI as quads & triangles - that will end up using MoI's triangulator which won't do that.

I think it is also possible to manually edit the triangulation of an n-gon in C4D if you want to change how the n-gon is being diced up, there is something in C4D under Tools / N-gon Triangulation, I'm not quite sure how it works though.

One other thing to mention - it is pretty hard to see the triangle problem in an actual rendering, it is much more pronounced when you're zoomed in and looking with the real-time view.


I may be able to try and reduce the creation of this kind of shape in the future, but it is actually a proper n-gon, I mean it is not technically messed up or anything like that. It would be good if C4D would create a better triangulation for it.

It may be pretty difficult to describe this to Maxon, but I hope that the step-by-step triangulation illustration that I showed above may help...


Also, one other note - there is a setting you can tweak in the moi.ini file to change how MoI will produce a triangulation for things like that, by default it will do a kind of radial triangulation when possible, adding an extra point in the center of n-gons like that. It is possible to turn off that style and instead only use points along the outside of the n-gons, let me know if you want more info on that.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1620.16 In reply to 1620.14 
Hi Dirk, just one other comment if you want to submit this to Maxon as a bug report, I would suggest deleting all the other polygons except for just one single one that has the black thing on it (but before yanking the points around), and then sending a file in with just that one n-gon in it as an example of the triangulation problem.

It helps a lot with bug reports to have the most simple data set possible that shows the problem.

It may not be a very easy thing to fix though, it can take a pretty big re-working of the triangulation mechanism to make one that does not back itself into a corner like this.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  WillBellJr
1620.17 
If you're having problems getting OBJs into C4D, I recommend you try the RipTide plugin:
http://skinprops.com/riptide.php
http://skinprops.com/fr_rtdocs.htm

C4D is known to have quirks and limitations to its OBJ importer hence the reason why RipTide was created...

-Will
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  vinced
1620.18 In reply to 1620.17 
Thanks Will,

i`ve just tried Riptide, but unfortunately it doesn`t work in this case.
By the way, is it possible to direct someone directly to this thread?
The url in my browser just says: http://moi3d.com/forum/index.php?webtag=MOI


Greetings Dirk
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  DannyT (DANTAS)
1620.19 In reply to 1620.18 
vinced, middle mouse button new tab.

http://moi3d.com/forum/messages.php?webtag=MOI&msg=1620.1

~Danny~
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  WillBellJr
1620.20 In reply to 1620.18 
Usually all the way at the bottom of the page there's an "All" link or "1-nn" link, those will also take you to the first post of the thread you're in. ;-)

-Will
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
Show messages:  1-20  21-22