Problems selecting objects
All  1-8  9-17

Previous
Next
 From:  JTB
1178.9 
My card is Nvidia GeForce 6600 GT, I opened some properties dialog and I saw that there was a setting about Direct3d and OpenGL settings that was set to balanced (between quality and speed). I changed it to "Let the 3d app decide" and it seems to make a difference... I test it and have no problems now....

I will update the driver anyway, although I think the only difference will be some added products that are supported....

I hope I did it and that everything works OK now, it was very annoying...
***Modeling Of Ideas***
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1178.10 In reply to 1178.9 
Hi JTB, hi xrok1, I remember some more details now.

When MoI does this "behind the scenes" render for selection, it needs to perform it with no anti-aliasing.

MoI tells Direct3D to do no anti-aliasing on this render, and then Direct3D tells the device driver.

But there was one version of the nVidia driver that didn't listen and did anti-aliasing anyway, if you had set it to be turned on for everything in the driver settings. There will usually be some setting for forcing anti-aliasing on in the driver settings, and that slider that you adjusted kind of wraps up several settings including turning anti-aliasing on or off.

I'm pretty sure that this has been fixed in later versions of their driver so that it listens to MoI's command to turn off anti-aliasing for this one particular selection thing. So once you update to a new driver version you should be able to have that setting to whatever and MoI will work ok.


@xrok1 - I'm pretty sure that this is your problem as well, that kind of incorrect targeting is happening due to the selection data being antialiased which mutates it. If you right-click on your desktop, a context menu will come up and you should probably have a menu item on it for "NVIDIA Control Panel". On the left panel go to "3D Settings", and under the "Adjust image settings with preview" entry, if you set the option to "Let the 3D application decide", it will disable this forced anti-aliasing and I think you will then be running properly. There is also a way in there where you can leave it on globally but have a different setting just for it to be disabled for MoI.exe, which would also probably work. Also if you update to the newest driver version I think your problem will also probably go away.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  JTB
1178.11 
Thanks Michael. it seems to work now, actually I think it was fixed before the new driver installation... Just had to let the 3dapp decide instead of using a standard quality/speed setting
***Modeling Of Ideas***
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1178.12 In reply to 1178.11 
Hi JTB, that's great!

xrok1 - please let me know if you have any trouble finding this setting or if the problem continues after that.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  xrok1
1178.13 
Micheal, changing the setting solved the problem for me also. thank you, i have to admit it could be more than a little annoying at times.

i appreciate your time and knowledge.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1178.14 In reply to 1178.13 
Hi xrok1, that's great!

I would still recommend installing the newest video driver that you can find though, especially on Vista newer video drivers can be tuned up for better speed as well.

Since Vista uses a different kind of video driver system than XP some of the earlier drivers for it were not really fully tuned up yet.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  xrok1
1178.15 In reply to 1178.14 
thanks for the suggestion, i am currently running the latest drivers.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
Next
 From:  Michael Gibson
1178.16 In reply to 1178.15 
Quick question - were you running into this problem while you were already running with the latest drivers, or did you update the drivers just recently?

If the latest drivers also have this problem that would be good for me to know.

- Michael
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged

Previous
 From:  xrok1
1178.17 In reply to 1178.16 
this problem persisted with all drivers i've used even the newest beta drivers. nothing solved it until i changed to the suggested nvidea control panel settings.
  Reply Reply More Options
Post Options
Reply as PM Reply as PM
Print Print
Mark as unread Mark as unread
Relationship Relationship
IP Logged
 

Reply to All Reply to All

 

 
 
Show messages: All  1-8  9-17