Full Version: Tiles and tile maps

From: bemfarmer [#10]
 6 Nov
To: ALL

Thanks James.

I've fallen behind on all the node editor posts, due to too much work/family duties, and did not realize your prior activity:-)

Currently looking for Surf convert .js

- Brian

Maybe it is hiding in a macro?
OK, it is in a macro, but I still need isoCrvs.js :-)
OK, basicfunctions goes under libs subdirectory in extensions.
Also, should add to nodeeditor wiki docs to check out macros, if a node is red (missing).

OK, do Karsten's menu cleanup from here:
http://moi3d.com/forum/index.php?webtag=MOI&msg=8628.1
Then do the object2.js update from James.
Now Jame's Truchet.nod runs.
To fix Jame's RandomWrap7.nod, replace IsoCrvs programming rectangle with IsoCrvs rectangle from construct2 menu.
Delete the old IsoCrvs rectangle, and Save the menu-updated node to RandomWrap7.nod.
(should add to wiki)
(Note, IsoCrvs was in a test menu area, and Karsten moved it to construct2 menu.)

Reply


From: James (JFH) [#11]
 6 Nov
To: ALL

Hi Brian,

I awoke to your tortured post of all the obstacles you
had to surmount in order to get my .nod files to run.

It was a worthwhile exercise to go through,
to update to NE mod with Karsten's rationalised menu,
however I'm sorry that I had not updated my earlier
post attachment. It is done now.

Are you a windows user? I only ask because Karsten
outlines a streamlined method of updating old .nod files
to work with his new NE mod. Found in his original post:
http://moi3d.com/forum/index.php?webtag=MOI&msg=8628.1

James

EDITED: also updated attachments:
http://moi3d.com/forum/index.php?webtag=MOI&msg=7777.585

Reply


From: bemfarmer [#12]
 8 Nov
To: ALL

Hi James,
Never owned, nor used a Mac, maybe someday.

Figuring out a little about the nodes was a great learning experience, and helped understanding forum talk.

- Brian

Reply


From: bemfarmer [#13]
 8 Nov
To: ALL

I'm making slow progress on my 2D Truchet tile script, and had a question.

I would like to keep edges of a few 2D surfaces hidden, as they impact the display of the surfaces.
But even after hiding the edges, Copy un-hides the edges.

Is it possible to do a Copy, and keep the edges hidden?

- Brian

Found an answer:
http://moi3d.com/forum/index.php?webtag=MOI&msg=8239.2

Reply


From: James (JFH) [#14]
 10 Nov
To: ALL

Hi Brian

I have returned to original truchet pattern, but with a different approach.
To do this I have created a macro: ArcCenter. Hopefully this will be replaced
with an Arc node with centre, 3 points and tangent options in the near future.

Given that it is covering old ground, I have posted it here rather than
"playing with nodes" thread because I thought it may be a interest to you alone.

Have a great weekend
James

Attachments:
truchetSweep.nod

Image Attachments:
truchetSweep.nod.jpg 

Reply


From: bemfarmer [#15]
 11 Nov
To: ALL

Hi James,

I have not studied the node, but made some observations:
Formation takes about 30 seconds +/-.
Apply yields "exception occurred, line 528", and geometry vanishes when node editor window is closed."
But I was able to save the geometry to a .3dm at about 30 seconds+, while node was open.

Note: Slot of a basic math node is remove-able by right clicking on dot.
I need to learn meaning of wire colors...

- Brian

Reply


From: James (JFH) [#16]
 11 Nov
To: ALL

Hi Brian,

<< Formation takes about 30 seconds +/-......exception occurred, line 528>>

That's odd...For me node generates result in 8 seconds, without error message.
I wonder if someone else might run this nod file and see if issue is repeated:
http://moi3d.com/forum/index.php?webtag=MOI&msg=8663.14

<<and geometry vanishes when node editor window is closed>>

That's true for all (or most) nod files. You need to click "Apply" button to bake out geometry, otherwise it is a preview only.

<< I need to learn meaning of wire colors...>>
Greenish = numbers
Magenta = points
Yellow = objects

James

Reply


From: James (JFH) [#17]
 11 Nov
To: ALL

Hi Brian,

I have uploaded a revised version of file (attached)
that is reduced in file size by more than a third,
though it does not run any faster (still 8 seconds for me).

Please try, and if error persists, please take screen grab
of error message, so that I might ascertain in which node
the line 528 exception lies.

Thanks
James

Attachments:
truchetSweep3.nod

Reply


From: bemfarmer [#18]
 11 Nov
To: ALL

Hi James,
Time is still about 30 seconds, on my very good Windows computer, with lots of memory and SSD drive.
Apply causes exception, copy attached.
Possiby my nodeeditor setup is different than yours. (?)
File is ~4,144 kb.


- Brian

Reply


Message 8663.19 was deleted


From: bemfarmer [#20]
 12 Nov
To: ALL

Hi James
After nap, here is the exception.
Copied your extensions. Construct2, max_subdiv..., and basicFunctions slightly different.
Same 30 seconds, same exception upon apply.

- Brian


Image Attachments:
ExceptionLine528TruchetSweep3.png 

Reply


From: Mike (MGG942) [#21]
 12 Nov
To: ALL

Hi, James,

I had some trouble running the nod, but after copying your extension folder, all works properly.
Takes about 7 seconds.

Mike.

Reply


Message 8663.22 was deleted


Message 8663.23 was deleted


From: Max Smirnov (SMIRNOV) [#24]
 12 Nov
To: ALL

I tried to reproduce this error using extensions files from James' post.
Everything works good for me. I tested this node with the last NE release (v.0.97) and with v.0.98 (not released yet).

Reply


From: bemfarmer [#25]
 12 Nov
To: ALL

Very weird.
I renamed nodeeditor directory, and reinstalled version 0.97 to a new nodeeditor directory, and loaded Jame's extension subdirectory.
Same 30 second, error message.
(One time MoI crashed.)


Also tried computer reboot.

Tried loading nod from shortcut key, same result.

- Brian

Reply


From: Max Smirnov (SMIRNOV) [#26]
 12 Nov
To: ALL

Hi Brian,
Right now I tested this node with NE 0.95, 0.97, 0.98 using Win and Mac versions. ~5 seconds. No errors on Apply.
Try to rename moi.ini file and run MoI with default settings.

Reply


From: bemfarmer [#27]
 12 Nov
To: ALL

Thank you Max.

I saved my current Moi.ini file, by renaming it.
I was unable, so far, to locate default Moi.ini, but saw one called MarvsMoi.ini, from 2015, and renamed it Moi.ini.

Success running the truchetSweep3 nod, about 6 seconds., and apply works, 0.97 version.

So something in my previous moi.ini file causes the previous failure...

- Brian

Reply


From: bemfarmer [#28]
 12 Nov
To: ALL

OK, reverted to my moi.ini file that caused the problem.
My mesh angle was set to 1, (very low).
Changed mesh angle to 15, and now the truchetSweep3 nod works just fine.
(Maybe caused a memory problem with too low a mesh?)

- Brian

Reply


From: Michael Gibson [#29]
 12 Nov
To: ALL

Hi Brian, yes a mesh angle of 1 degree will generate very dense display meshes. That would make it likely to run out of memory when dealing with more complex geometry and also take quite a bit more time as well.

- Michael

Reply


Show messages:  1-9  10-29  30-40

Reply to All

Back to thread list | Login

© 2017 Project Beehive Forum