stl export

 From:  Michael Gibson
630.4 In reply to 630.3 
Hi Matt, Tim sent me the file through e-mail and it appears to be writing out an STL, but the mesh had some really long and skinny triangles in it which the Roland software on the other did not seem to like.

If you are running into the same problem, you may need to adjust some mesh settings to avoid really long and skinny triangles. To do this, when you save the STL file, use the little arrow on the lower left hand of the meshing dialog to open up the detailed settings, and then try entering a 1.0 in the "Aspect ratio limit" box.

That will divide polygons that have a wide aspect ratio (like for instance if one side is 17 times the the other side, that is an aspect ratio of 17:1 ) into smaller pieces until they try to approach more of a square shape. That is one way to avoid long and skinny triangles.

The other setting that you can also experiment with is the "Divide larger than:" setting - here you can enter a distance and any polygon that has an edge larger than this distance will get subdivided. So for instance if you put in 2.0 there, any edges longer than 2.0 units will get divided further, this can also help to reduce long skinny triangles.

I will see if I can tune up the mesher a little bit to try and avoid them somewhat more by default though.

- Michael