3dmCurves2DXF not working with 'MoI 3.0 beta Oct-25-2011' created files

 From:  Michael Gibson
4840.8 In reply to 4840.7 
Hi eric,

> I tried to unzip and install the latest version but get
> the message that there is a system error ...
> I don't have zlib1.dll

You would get that error if you tried to run the .exe file just directly from the .zip file without actually unzipping the whole thing. When you do that it the windows shell basically unzips just that one file to a temp directly and then tries to run it - but in order for the .exe to run correctly it needs all the files that are included in the .zip along with it to all be unzipped, not just that one file alone.

So try right-clicking on the .zip file and choose "Extract All..." from the context menu that pops up - that will then actually unzip all the contents of the zip file which has 4 files in it (including the zlib1.dll file which the error message mentions) and with those 4 files all together in a folder you can then double-click the .exe file and it should then run ok.

When you just double-click a zip file in windows explorer, you actually haven't really unzipped it yet, you're only getting a view of what is contained inside the .zip . In this case you need to really unzip it and get all the files in it extracted in order for it to work.

Please let me know if this still doesn't make sense or if you're still stuck.

> Will MoI 3 have the ability to export dxf files in the next beta?

I'm not exactly sure when it will happen, probably sometime during v3 but it does not seem likely to be in the very next beta though.

- Michael