loft question

 From:  Michael Gibson
4755.2 In reply to 4755.1 
Hi niko - that's happening if you use the "Profiles: exact" option, correct?

Try switching back to the default "Profiles: Auto" or use "Profiles: Refit" mode instead and that should go away.

An exact NURBS circle is actually a segmented series of 4 arcs and in some cases that quadrant segmentation can cause artifacts where things don't go smoothly across segments.

When doing a refit of the loft sections, that segmentation is removed since it basically uses rebuild on the exact circles and that reduces any chance of different sections being handled separately and having creases form.

You probably didn't like what you initially saw when you used the Profiles: Refit mode since it looks a little odd:

But there's actually nothing really wrong there - that's just a display artifact where not quite enough polygons got created for the display mesh in some of the slightly curved areas that you happen to have. If at export time you generate enough polygons in the whole thing you'll see the actual surface is not so messy:

You also may want to use the "Divide larger than" option at export time to make sure that the polygons are getting diced up enough - if you have subtle undulations you can need more polygons than the angle metric alone for determining subdivision.

You might try something like a value of Divide larger than = 2 so that any polygons larger than 2 units in size will get subidivded down and that will help to bring out the true shape of the surface better rather than having low polygon artifacts sneaking in.

- Michael