From:  Michael Gibson
4741.4 In reply to 4741.3 
Hi Martin, when you do a File > Import into MoI, it merges the file you pick into the current model and various settings like the current unit system will stay the same as they were before.

There is a setting for whether you want to have an import of a different unit system to be scaled into the current system or not - have you possibly disabled that option? If so then that's probably the problem.

Please take a look under Option > General > Unit options:

Push that button to bring up this dialog:

Make sure both "Scale on unit system change" and "Scale when importing different units" are both checked. They should be on by default, but if you unchecked the option to scale on import then that would cause the kind of problem that you are describing.

Also another way you could do it is to use File > Open to bring the file into MoI, which compared to File > Import replaces all content with the file you pick and also the unit setting of the file will become the current units.

If you do that you'll see that the units in the file happen to actually be set to Inches for whatever reason by Viacad (with objects scaled accordingly to preserve them to the same size as you had in mm) and then if you change the unit system to mm you'll end up with the result you want, as long as you have "Scale on unit system change" also turned on in the above dialog.

Does that help? Please let me know if you are still seeing a problem.

- Michael