From:  Michael Gibson
4741.12 In reply to 4741.10 
Hi Danny, I think it's one of these files that has units set to something like MM but with an additional scale factor applied to it which actually makes the real units as inches if you take mm times the scale factor.

Martin - there was a bug in the regular MoI v2 release that did not deal with that kind of unit setup properly, it misses the scale factor that's additionally applied to the unit system.

There is a patch available that can be applied to the full v2 release which fixes a couple of bugs and adds a new lwo export feature, it can be found attached to this forum message here:

If you apply that patch to the full release version of v2 then your STEP import will work properly after that. It's also fixed in the v3 beta releases as well.

I do not currently have any version of that patch for updating the v2 trial version though.

So the bug in the trial version that you're currently using is that MoI thinks that the units in the file are MM when actually they are stored in inches in the file itself (when you take the MM unit setting and also applied scale factor together into consideration).

So in order to get the units correct in your trial version of MoI, you will need to get the units converted from mm to inches without applying any scale factor to the objects. Then after that you can switch to mm with a scale factor applied which will then end up with the proper result.

The easiest way to do that is to leave those 2 checkboxes turned on, and then do the following:

Do a File > Open of any of your files.

You'll now see that the units are set as mm - this is actually incorrect, the objects at their current size are actually in inches units.

So now go to Options > General and switch the unit system from mm to "No unit system" - switching from any unit system to "no unit system" does not change the scale of the objects. Now switch the units again to Inches. Again there will be no scaling applied since you're coming from "No unit system" into inches. At this point the objects are correct. Now you can switch from inches to mm and the objects will scale and you'll have the proper final result.

Sorry for all my confusion over this, I had that patch applied to my regular v2 version and so I did not run into the same bug that you ran into with the no-save trial version. That caused me to get really confused as to why I was seeing a different result from you.

Hope this does now explain things properly!

- Michael