export option and unexpected result

 From:  Michael Gibson
4012.5 In reply to 4012.1 
Hi PP,

> then I add a value "Divide larger than"/"plane" (polygons
> don't seem regularly created)

It seems like you may have created something that had some polygons that were just about exactly equal to your "Divide larger than" setting.

It's not unusual for floating point calculations on the computer to give a very tiny amount of fuzz which can put some values in your case just under your tolerance and others just above the tolerance. The ones that are just above the tolerance will then get subdivided.

For other situations you won't see that kind of a thing - for example here I created a cylinder which must be of some other size than your particular one, and I get this result instead:

So it's most likely related to the particular size of your cylinder causing some polygons created which are very close to your "Divide larger than" setting. For your case you should be able to avoid the problem by using just a very slightly larger value for your "Divide larger than" parameter so that your parameter does not come so close to some polygons that are being checked to be subdivided or not.

> When using 54°, polygons don't seem regularly
> created for both plan and curve :

That's going to be the same kind of a thing - some polygons were just slightly over the tolerance value and those ones get subivided into half.

One thing to keep in mind is that it's not possible for the mesher to just evenly subdivide everything in all cases because that would cause extremely dense meshes to be created on anything that has a just a little bit of irregular bumpyness in one localized area of a surface.

That's why there is this mechanism of a kind of "local refinement" to the mesher where it will subdivided quads into halves so that there can be more polygons in areas of surfaces that are more tightly curved and less in areas that are flatter.

I hope this helps to explain the results that you were seeing!

- Michael