Can't seem to create rounded shape

 From:  Michael Gibson
3761.2 In reply to 3761.1 
Hi NightCabbage,

> (right side - note the pinching towards the corner)

This is a bit difficult to explain, but basically when you make a network (and sometimes other surfacing tools) collapse down to a "pole" point it puts some kinds of stresses on the surface, it kind of forces shapes with different lengths to collide together and there is often that kind of a pinched result.

In your case here the blue and red sections have fairly different lengths to them:

Another way to try to describe it is that because these different lengths are being treated equally (being matched between them by distance traveled along the curves), it causes the cross-section of the surface to kind of twist (not only laterally but also kind of wiggling in 3D as well) as it approaches the tip, if you turn on surface control points you can kind of see that kind of twisting:

To get a more regular shape you actually don't want that kind of twisting, you instead would want more very regular cross-sections like this:

Using the Revolve command will make control point structures that have that kind of all straight sections, that's why Revolve can make very nicely formed rounded tips for things like this.

For Network you can often improve the shaping at poles by placing in an additional small profile closer to the tip - that kind of forces things to align in more parallel sections similar to revolve and reduces the twisting/buckling effect.

So for example in your case here it would mean adding in a section like this:

Try the attached rounded_2.3dm file to see if that helps with the tip shape.

> (bottom left - see how the surface goes outside the curve I specified)

Actually it goes to the curve you specified, you are just seeing the silhouette of a bulge. The bulging is caused by that same cross-section twisting/wobbling type effect that I was trying to describe above.

One other tool than revolve that can be good for this kind of a shape is Sweep with the "maintain tangent" checkbox option enabled.

I probably gave that option a bad name - instead of calling it "maintain tangent", I probably should have called it something like "parallel profiles", because it makes the sweep work by making all parallel planes between the profile curves rather than having the "slide along the curves by the same proportional distance" method which then makes that more twisted kind of profiles. But it only works with some kinds of inputs, you have to have profile curves all on parallel planes to start with.

So for your case here, pick the short curve initially which will be the sweep profile, and then run Construct > Sweep, then pick the 2 longer curves as rails. Initially you will see a similar kind of tip as you originally got, but then turn the "Maintain tangent" checkbox option on, and you will see it go away. Check out the attached rounded_3.3dm file.

And note with this sweep + "maintain tangent" method, if you turn on the surface control points and look at them in the Top view, you'll see this:

So note there that with that option enabled, the surface control points are all on parallel planar slices, so it avoided that kind of twisting effect that happens when sliding a connection along different length pieces.

Hope this helps explain some of the issues!

- Michael