Bug reports

 From:  Michael Gibson
3252.4 In reply to 3252.3 
Hi Tree, thanks for posting the file.

Over here, it seems that disabling apparent intersections actually solves the problem completely. And this is on a 6 year old machine with an old video card...

What degree of performance lag do you still see with it disabled?


It's going to be difficult for me to fix this for v2, I'm probably going to have to add it to my list to look into for v3. It's probably not feasible to really speed up the calculation itself, I'll need to figure out something else, like maybe not doing an apparent intersection on a curve that ends up doubling over itself so many times like this, or possibly doing it on a separate thread.

For now there are a variety of workarounds though - hide the helix, turn off apparent intersections, or disable snaps temporarily while working just in that area where the helix is at... You can also hold down Alt to temporarily disable snaps instead of using the toggle button in the UI.

- Michael