Exported objects looks ugly (screenshot provided)

 From:  Michael Gibson
3241.4 In reply to 3241.3 
Hi Ola, thanks for sending me the model through e-mail.

Unfortunately I can't seem to reproduce the problem over here - when I save the model you sent to LWO format and then load that into Modo 203 over here, I get the following result:

Also testing the LWO file going into Cinema4D v10 gives this result:

Unfortunately I do not have LightWave here to test with currently.

But all the polygons seem to be there ok. From your screenshots it looks as though the problem may be some kind of messed up vertex normals and not necessarily missing polygons.

The mesh settings I used were slider all the way to the right (so Angle = 3, the slider controls the Angle numeric parameter on the expanded dialog) and Output: N-gons.
Are you using some particular mesh settings to get your problem result?

What happens if you delete vertex normals in LightWave? There should probably be some kind of mapping entry for them similar to UV coordinates. If you remove them it may recalculate them by averaging them from the polygon normals, which tends to give not as perfectly smooth looking of a result but could also repair any badly mangled ones.

Also are you running any other steps on the model after importing it, like merging vertices or anything other than just a simple import? If so then possibly LightWave is not handling vertex normals properly during that step. That would not be surprising since importing vertex normals is a relatively new feature in LightWave.

Finally, I did recently uncover a multi-threading synchronization bug in the mesher, I'll send you a patch that fixes that just in case that is what you were running into but it was pretty rare.

But try deleting vertex normals, and let me know if you are doing any other editing steps in LW after importing.

- Michael