On surface snap in ortho views

 From:  Michael Gibson
2267.2 In reply to 2267.1 
Hi PaQ - with the Nov-21 beta there is a new moi.ini switch to disable or enable OnSrf in the ortho views, and the default is disabled.

It's because of this problem - say you have a scene like this:

Now say you want to do some 2D drawing, so you go to the top view and draw some shapes:

However, if onsrf is enabled even though it looks like you got a 2D drawing, what you actually get is this (seen here from a side angle in the 3D view):

The base point of each drawn object ended up on a different elevation due to the onsrf object snap kicking in.

The same thing happens with other object snaps as well, but OnSrf is a little different than the other kinds of snaps in workflow since it can pretty easily fill the entire screen to be completely full of snappable areas.

The focus of the ortho views is for doing 2D things, so disabling OnSrf in those views kind of helps to prevent some kind of unexpected elevation shifts. When you're working in the 3D view then the assumption is more that you want to be free to pick things at any elevation and have less 2D-ish type behavior in there.

You can re-enable OnSrf in ortho views by this switch in the moi.ini file:

[Drawing Aids]

If you switch that to =n , then OnSrf will be allowed in the ortho views the same as previous v2 betas.

- Michael