consider please some corrections

 From:  Michael Gibson
1935.2 In reply to 1935.1 
Hi Allan,

> When pressing Ctrl+C to evaluate copy: do not close
> already open tool choises or active command.

There are some difficulties with doing this, since many commands may make temporary changes to the geometry database while they are active. For instance, it is not uncommon for objects to be temporarily hidden while newly calculated results are being displayed. Selection is also often temporarily changed while commands are running.

It helps to ensure a totally normal object state by making the Ctrl+C copy command exit any running command first before it makes the copy.

But if you would like, it should be possible for you to change what the shortcut for Ctrl+C does so that it will not cancel a running command. To do this, go to Options / Shortcut keys, and find the entry for Ctrl+C.

For the Command part, it will currently say: CopyClipboard

Change it to this instead:
script:var gd = moi.geometryDatabase; gd.copyToClipboardCommand( gd.getSelectedObjects() );

With your Ctrl+C shortcut edited to use that script instead, it should behave the way you are asking about where it will not interrupt the current command. But for commands that are modifying the selection, you will need to push Cancel or hit the Escape key manually before you do the Ctrl+C to get the selection restored before you do the copy.

> And when pressing right mouse button to repeat a command; do
> not consider paste: let it be only available via Ctrl+V

This one is possible to set up by editing the moi.ini file - on Windows XP this file is located here:
C:\Documents and Settings\ [your login name] \Application Data\Moi\moi.ini
It is in a slightly different location on Windows Vista, let me know if you need that info.

Shut down MoI first before editing the moi.ini file (because it writes out settings when it exits so you don't want it to overwrite any of your edits), and then you can edit in in a text editor like notepad.

Find the [Commands] section, and there is an entry under it for NonRepeatingCommands, it will look like this by default:

NonRepeatingCommands=delete undo redo

Change this to add paste at the end, like this:

NonRepeatingCommands=delete undo redo paste

Once paste is on that list then it will not be targeted for repeating with the right click.

So I think those changes should make these things function like you want, please let me know if you have any problems setting them up.

- Michael